Failed to create administration group!


I installed webmin and virtualmin on a freshly installed Debian sarge server. When i create a new virtualserver i get the following error:

Setting Up Virtual Server
In domain
Creating home directory …
… done

Creating administration group lemonsolutions …
Failed to create administration group!

I have no idea how to solve this :s

Hey Jelle,

This is a known issue with nscd. Here’s the FAQ about it:

Shutdown nscd, and things will begin to work fine. You’ll need to remove the remnants left behind after the failed creation (I believe it’ll just be a user that you need to delete using the Webmin Users and Groups module).

Now that we’re aware of Debian enabling this piece of crap^h^h^h^hsoftware by default, we’ll set the installer up to turn it off during install. It does nothing good in a system that isn’t tied to NIS or LDAP. :wink:


thanks alot, that worked like a charm.

As a follow up problem:

When i created a virtualserver i now get this error in my apacke2 configuration:

Failed to start service :

Starting web server: Apache2Syntax error on line 395 of /etc/apache2/apache2.conf:
Invalid command ‘SuexecUserGroup’, perhaps mis-spelled or defined by a module not included in the server configuration

I guess i did something wrong when changing the module config in the apache server to apache2.

I am getting the same error but am using ldap (for qmail-ldap). I have tried with and without nscd installed and/or running.

OK, I went back to ubuntu, and am now trying to enable LDAP/Samba PDC for my SSO solution with Windows.

I am experiencing this issue of virtualmin not finding a freshly created LDAP group, but have no nscd installed, and a getent group shows my group is being recognised by the name service switch.