Failed installation

Today i try to install Virtualmin on new VPS with fresh/clean Centos 7 and i had failed install (first i ever had). After i re-install Centos for third time i start to look what could be the problem and only error i found in log file was:

Error: Package: php-imap-5.4.16-3.el7.x86_64 (virtualmin)

After i installed epel the installation was done without any problem. This is not first time i’m installing Virtualmin on VPS but i never needed to install epel before.

Did something changed or i should file bug report? Ok i try one more time and here is entire log:
I try without update of Centos 7 and with but same output. Any idea what is going on?
Edit: Even the installation was done after i installed epel i got clamav error during post install.

From the minimal install ISO there seems to be a dependency on libc-client by IMAP that’s not handled properly by the installer (not in the normal repos and not provided elsewhere). Installing libc-client-2007e before running the installer (along with perl and wget and curl as noted in the docs) let the installer work fine for me.

That could be true only if within same hosting company they put different versions of Centos 7 on different servers what would be something i never saw before. Because i have several VPS with same company and on all of them is Centos 7 and i never had any problem to install Virtualmin.
But before i start anything i would like to know if this is Virtualmin problem or something is wrong with my last VPS and/or Centos 7.

I’m not sure about your providers setup. My experience is from downloading the minimal ISO from Centos and noting down what I had to to to get the installer to run.

This is something that just broke. I installed this in a VM last week and it worked fine.

I saw someone mentioned installing libc-client-2007e but that is not in the CentOS 7 repos.

Yea, the dependency that broke is libc-client. I didn’t find a el7 version either. To work around it I installed the el6 version before running the installer. I haven’t noticed any issues but haven’t done any major regression testing yet. It looks like it’s part of the base repo in 6.

My only problem here is what i cant figure out if this is because of Virtualmin or something is wrong with my new VPS. Just before few days i installed Virtualmin on Centos 7 without any problem (same hosting company).
@Steffan. You are right no libc-client-2007e for Centos 7 and aside of this Virtualmin “prefer” clean/fresh OS so i dont see any point in installing some extra repos because Virtualmin should pull all dependencies during the installation.

I was thinking the same but it doesnt help me to spot where is the problem. Because if this is something new from Virtualmin then there should be bug report and if this problem is part of my VPS then i need to talk with my provider. It would be better to put the light on the cause then patching things up not knowing why in first place i had an error.


Thanks for pointing this out, we are indeed looking into it.

We recently added php-imap to the CentOS 7 repository, as it’s not included as part of CentOS 7.

However, it appears to require the package that Peter Clark mentioned.

What I’ve done for the moment is to temporarily remove php-imap as a package that’s installed during the Virtualmin installation. That should prevent installations from failing.

Then, we’ll determine how best to resolve that dependency issue with libc-client-2007e.


Ok thank you Eric, i was thinking i’m going crazy. Lost so many hours trying to figure out what is wrong. I saw that dependency issue but was not sure if something changed with Virtualmin. Virtualmin change log didnt mention anything about php-imap or somehow i miss this part.


Yeah that wasn’t part of a Virtualmin release. That was performed independently, after we realized that php-imap wasn’t being provided with CentOS7. We added a version of that in there, but now we realize we also need to include that dependency.


I will drop for now Centos 7 because i encounter too many problems. I think i will wait another year and then try again in mean time Centos 6.6 should work as intended. MySQL, php and the rest should be fine for that time and probably one year is enough to “polish” Centos 7 and other scripts.

I found the Virtualmin script to work smoothly on Cent OS 7 after adding the EPEL repo. I did as below and then re-executed Virtualmin install script which worked smoothly.

yum install epel-release

The only problem I encountered was with ClamAV. However I only had to move the config file to old location expected by ClamAV as below.

cp /etc/clamd.d/scan.conf /etc/clamd.d/scan.conf /etc/clamd.conf

Edit both clamd.conf and freshclam.conf under /etc find following lines

Comment or remove the line below.


Comment Example as below in both files.


After this, all started to work smoothly.


It’s not actually necessary to enable the EPEL repo – there was a particular dependency problem that occurred with php-imap, but that’s now corrected in the script.

We’d advise caution to anyone enabling a third party repository, as it can cause some unusual problems. If a package from a third party repository is needed, which can sometimes come up, our suggestion is to just install that one package, rather than globally enabling the repository.


Hi Andreychek

Actually I have tried to install Virtualmin followed by Webmin only yesterday on a fresh install of Cent OS 7. It has given me loads of errors, not just one missing library and I was almost given up with Cent OS 7 until I easily sorted out it by adding EPEL repo.

I have seen a comment on another thread having the possibility of 3rd party repos causing the problem, but I didn’t have any on my fresh install at that time and the Cent OS 7 was fully updated.

Thank you !

The issue I described was fixed today.

Also, we haven’t been able to reproduce any issues with installing Virtualmin on CentOS 7.

If you’re seeing any issues, let us know, as it definitely should not require a third party repository to get Virtualmin up and running on CentOS 7.


Dear Eric

I have already completed installing my server and it is up and running. So there is no way I can re-produce the issue.

It is better to try without any 3rd party repo as you said, I agree. I wish the great Virtualmin will now smoothly install on Cent OS. Many thanks goes to the fantastic Virtualmin team. It is truly and excellent software and probably the best server/web management panel available today.

Just downloaded virtualmin gpl and ran into this same issue.

Sorry for that – can you try re-downloading the, and attempt running it again?


Actually, loaded the missing module from epel and install went fine. So, too late. However, I have more machines to load in the coming month and will report if it fails again.