Failed filesystem migration after broken gpt table need help

Yup, I really went and did it this time boys and girls. I did a dd and made a copy of my partition after I borked up the GPT layout or something trying to convert the table so I can make sue of this multi TB sas array I just built… Then I did another thing and now this thing plus that thing leads me here to needing to recover the data from the virtualmin install, vhosts, and databases now. (Mounted on another drive) to this beautiful clean new install. Everything was installed in / and the new system is as close to identically configured as I can make it.

Ubuntu 20.04 LTS (Jammy)
Virtualmin just pulled down via wget right from the source
Fresh install and updated
Identical permissions

Copy and paste into sda5 and boot? NAAhhahahah Ask me how I know.


I have to ask and I mean this in all seriousness: are you trolling? Is this a joke?

This is not a joke. I tried to copy my partitions to a new array and didnt have full size because of needing the partition table to be gpt for the TBS size array. That conversion to GPT left it unbootable and unusable. So I made a backup of the files on the disk to my SSD and created a clean install of my OS on the system.

Now I need to get the backup files put where they need to go in virtualmin?

If you backed up your Virtual Servers using the “Back Up Virtual Servers” dialogue in Virtualmin, then all you need to do is install Virtualmin on the new drive / partition and restore them.

If all you did was copy the files onto a disc or drive and then try to just paste that into a new install…

I have no idea how that could ever work or how you would fix it.

The original array is offline now. So I guess I would have to rebuild it and login to it and manually run the backup command and copy those zip files to the external drive. Then rebuild the array with my fresh install. Copy those files to the /root/backups/and run the restore-domain string.

That is all supposing that the old array could even boot, I don’t believe it has a valid boot partition because of conversion to GPT.

you do understand disk arrays ?

Bump! Bump! :computer: :minidisc: :floppy_disk: :cd:

I don’t understand the problem you’re having. It sounds like it’s not yet a Virtualmin problem…if you don’t have Virtualmin backups, and you don’t have the old Virtualmin installation in an accessible form, it seems like you have a generic Linux problem (which may be better addressed somewhere like Server Fault, due to larger community).

Or, do you actually have access to the old data somehow and just don’t know what to do with it?

I have the original array still, I just have to populate it in the server to access it I believe. So from what I have read, it is a simple process to make the backup and restore it into the new machine. I am also not sure if this disk array is bootable anymore. I guess there is only one thing to do right now.

I still don’t know what you’re trying to do! What do you mean “populate it in the server to access it”?

Do you have the old system data (the important ones would probably be /etc, /var/lib, and /home), or not?

Who cares if it’s bootable? If you can mount the filesystems and read the data, you have the data and you can work with it or copy it to a new system or whatever you’re trying to do. You could even chroot to it and start Virtualmin in the chroot.

But, it’s still not clear to me you have access to the old data. Can you say plainly whether you have the old data or not?

Yes, I have the data. I am logged in to the machine right now and creating the backup of the virtual servers and settings. Now am I to assume that the restore process is just as straight forward? Its going into a clean install with only virtualmin and the lamp stack installed.

Yes. It is.

Even a cursory look over the Virtualmin menu would have shown you that. I mean, honestly - the menu literally says “Backup and Restore”. It’s not cryptic at all.

Open that up, and there it is right in front of you:

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.