Failed dependencies : No PHP version could be found for this virtual server

Fails updating scripts

SYSTEM INFORMATION
OS type and version Ubuntu Linux 20.04.5
Webmin version 2.001
Virtualmin version 7.3-1 Pro
Related packages

Did you remove the system default PHP packages? (i.e. as part of upgrading PHP)

This indicates Virtualmin doesn’t know about your PHP situation. You can Re-check Configuration so it’ll try to find PHP again.

But, you should not remove the default OS packages for PHP, even if you want a newer one…just install a second newer version. The package repos we suggest in our Multiple PHP documentation will install safely alongside the system PHP packages, without replacing them, and Virtualmin will be able to use either/or.