Failed backup... Need some help!


since a few days I get an error when launching a scheduled backup with Virtualmin (v 3.97). I’ve tried several settings to copy it to an external ssh-server. I’ve tried to backup only one domain, set another user and password, and so on)

I get the (german) message:

… hochladen gescheitert!’s password:
scp: /home/myuser/backup/backup_13-01-02_00-00-06/ Not a directory

I had a look on my ssh-server:$ ll
total 60
drwxr-xr-x 2 myuser admin 4096 Jan 3 10:17 ./
drwxr-xr-x 10 myuser admin 4096 Jan 3 10:02 …/
-rw------- 1 myuser admin 4200 Dec 31 01:55 backup_12-12-31_00-00-06
-rw------- 1 myuser admin 4191 Jan 1 01:57 backup_13-01-01_00-00-05
-rw------- 1 myuser admin 4193 Jan 2 01:57 backup-01-02_00-00-06
-rw------- 1 myuser admin 4198 Jan 3 01:55 backup_13-01-03_00-00-04

It looks like the backup-script doesn’t make a dir. But making a dir by “mkdir” in terminal works fine. Is there any error in the backup-script on my virtualmin-server?

Have you got any idea, how to solve it or how to get further information about the error? Any logs? I’m using Ubuntu 10.04 on my virtualmin and 12.04 on my backup-ssh-server.


Have got the same problem here, backing up over ssh to a Mac. Looking through the logs now, it started on the same day I upgraded to virtualmin 3.97, incremental backups with strftime substitutions were running correctly until then. After upgrading, files were created on the remote server instead of folders as the previous poster noted.

If I manually create the dated folder on the remote server, all works tickety-boo.

Hi guys… I’ll ask Jamie if he can take a peek at this thread. Since you have the “Create destination directory” option set, that sounds like the settings are correct…


I get the error-message since I’ve upgraded to virtualmin 3.97, too.


I understand that this all occurred after updating Virtualmin… but just to rule out one thing, what is the shell being used for the users on the remote SSH server?

Is it by chance the scponly shell?


Hi Eric,
it’s /bin/bash on my backup-server.


We have been experiencing backup failures all around as well. The problem is that no new directories are being created even though the option is chosen.

Well, the trouble is that we can’t seem to reproduce this :slight_smile:

I setup a new backup on one of my test systems, had it perform a backup to a remote SSH server, using a non-existing directory, and had strftime substitutions in the directory name.

It was able to create the directory and copy in the backup files.

We’re hoping to get to the bottom of what you’re seeing, but may need a closer look at the issue… would it by chance be possible to login to one of your systems, and manually run a backup?

If so, could you email login details to Jamie and/or I would then log into your system and take a look at what’s going on.



Hi Eric,

I’ve tried to reproduce this error, too. I’ve figured out, that my setted file-location began with ~/myuser/backup… This has worked without problems during the last month. Now I’ve changed it to myuser/backup… without tilde. And I think that was my mistake. The first file is created on my ssh-server and in a few minutes I’ll will get my message of success :wink: (i hope so)

Perhaps everybody involved in this thread can check, if you have set a path beginning with ~ ?

Thank you!

The backups failed December 30- January 4.

They have been working the last couple days. I changed nothing.

Is it possible that there is something date related with the glitch?

My Backup path is this:


Hope that helps. Thanks.

Guys , do you resolve the backup problem? I can backup only with manual backup .The scheduled backup is not working. Please help!

“not working”???

Have you tried to create a new job?

i’ve tried with no succes to do a schedule backup again.

I’ve created a new backup schedule but nothing happened.
This is my path /backup/%Y%m_%d_%H.%M.
I backup all my virtual server to local file.
I am using Virtualmin 3.98 GPL
I am doing everything right:
Backup destinations: localfile /backup/%Y%m_%d_%H.%M
Do strftime-style time substitutions on file or directory name is checked
Backup format One file per server Create destination directory? cjecked
Backup level Full (all files)
Complex schedule Every day at 07:50
What is wrong here?