failed backup after system time change

I recently changed the system time to be in sync with our local time zone, and since then the automated backups have been failing. It seems that it’s affected the communication with Amazon S3. I’ve recently changed the time back to reflect the original time zone, but the error is still happening. The error message is below:

“Failed to list S3 buckets : The difference between the request time and the current time is too large.”

Any thoughts on how I might sort this out?

  • jalen.

If you go into Webmin -> Hardware -> System Time -> Set time, are you seeing the correct time for your time zone?

Then, in the “Time Zone”, what is your time zone set to?

Also, in the “Time server sync” tab, make sure it’s setup to synchronize on a schedule.


webmin -> hardware -> system time -> set time: No it’s not the correct time for our time zone. I put it back to the time correct for the time zone it was originally. Just under the button on this tab (beneath a

line there’s a statement: “hwclock failed :”

The Time Zone tab/link has no content, nor does the Time Server Sync tab.

That’s what I see…

You are probably on a VPS? So you don’t have any hardware clock (permissions) :wink:

Yes. A Rackspace VPS.

However, I’m still curious about how this is impacting my scheduled backups, and the S3 file transfers in particular.

Well, I’m working with Jamie now (via email) on why those tabs are blank. That’s something we’ve been able to reproduce, so we’re working on fixing it :slight_smile:

However, I suspect that ultimately, the issue is due to a problem with the system time.

If you type “date” on the command line, is the time and date is lists correct for the time zone it lists there?


Okay, for getting those 2 tabs to work – if you go to Webmin -> Hardware -> System Time, and click Module Config -> System Configuration, make sure that “System supports hardware time” is set to “Detect Automatically”.

When that is set, Virtualmin will check the settings in /proc before trying to work with the hardware clock.


Hmm… using that command I just got: ‘Wed Dec 8 19:55:59 UTC 2010’ And I’m not solid with UTC conventions and daylight savings, but I believe that the current time (at that moment I ran the command was 20:55:59 UTC… one hour off. However, that could simply be because I made an error when I set the time back to what I thought the correct time zone time was…

I’ve made your recommended change, but it doesn’t enable the Change Time Zone and Time Server Sync tabs…

After browsing to one of those blank tabs, do you see any errors being displayed in /var/webmin/miniserv.error?


I’m seeing a lot of these messages:
“Error: hwclock failed :
Cannot access the Hardware Clock via any known method.
Use the --debug option to see the details of our search for an access method.”

But I think these errors are from Dec 6th…

FYI: I manually corrected the time again, and the backup errors have stopped. I believe it is because, this time, I set the time to the true correct time for the time zone the machine is in. However, the time zone support is still not available at this time. Any further thoughts on the matter?