Extending Home Space

Hi All,

I’m seriously confused at the moment, as I have done this before on my other server, but I cannot for the life of me remember how I have done it.

Basically I installed everything from scratch on a brand new server, but for some reason I only have 20GB of usable space, when there is 900GB partitioned into logical volume “home”

I think the volume that is being used at the moment is “root”, but how can i mount the “home” volume into /home/?

My current FSTAB


#
# /etc/fstab
# Created by anaconda on Thu Oct 17 20:22:04 2013
#
# Accessible filesystems, by reference, are maintained under '/dev/disk'
# See man pages fstab(5), findfs(8), mount(8) and/or blkid(8) for more info
#
/dev/mapper/VolGroup00-root	/	ext4	grpquota,usrquota,rw	0	1
UUID=f4337b7e-8e33-46ad-84eb-202b50186645 /boot                   ext2    defaults        1 2
/dev/mapper/VolGroup00-swap swap                    swap    defaults        0 0
tmpfs                   /dev/shm                tmpfs   rw,noexec,nosuid,nodev        0 0
devpts                  /dev/pts                devpts  gid=5,mode=620  0 0
sysfs                   /sys                    sysfs   defaults        0 0
proc                    /proc                   proc    defaults        0 0
/var/tmpMnt /tmp ext3 loop,rw,noexec,nosuid,nodev 00

Anyone have any ideas?

Hmm, I don’t see a separate partition for “/home”.

What output does this produce:

df -h

Output is as follows

[root@50 ~]# df -h
Filesystem            Size  Used Avail Use% Mounted on
/dev/mapper/VolGroup00-root
                       20G  4.0G   15G  22% /
tmpfs                 5.9G     0  5.9G   0% /dev/shm
/dev/md0              756M   56M  663M   8% /boot
/var/tmpMnt           2.0G   68M  1.9G   4% /tmp

Hmm, well, it appears there that your largest partition is 20GB, and that’s currently in use for the / partition.

Do you perhaps have a partition that’s not currently being mounted?

-Eric

Yes I think that is the issue, I have created a volume group “home” which I’ve tried mounting to /home/ but it wouldnt let me.

[code]Failed to save mount : Mount failed :

mount: wrong fs type, bad option, bad superblock on /dev/mapper/VolGroup00-home,
missing codepage or helper program, or other error
In some cases useful info is found in syslog - try
dmesg | tail or so[/code]

I managed to figure it out, I reformatted the partition using the ext4 filetype and then it allowed me to mount it on /home/

Super, I’m glad you got that working!