Expired certificate

SSL Certificate Warning

The following virtual servers’ SSL certificates have expired :

Validating configuration for developingcreativity.atrv.ro …
… errors were found, which will prevent Let’s Encrypt from issuing a certificate :

  • Apache website : An IPv6 DNS record … with address 2a06:98c1:3121::8 exists, but this virtual server does not have IPv6 enabled

Delete the IPv6 DNS record, or configure IPv6 correctly.

1 Like

I dont have IP6 enabled on my server. I only have NS through cloudflare!

Did you log onto cloudflare and double check?

I dont know about cloudflare. but on my server I dont have activated IPv6.
I dont understand why is doing like this, because I hove more domains on cloudflare and only one is doing this problem when I try to renew lets encrypt certificate.

How did you get the server running if you don’t know about cloudfare DNS settings?

The error is clear: You have an IPv6 (AAAA) record in DNS for this name. Let’s Encrypt validates both IPv4 and IPv6 if you have records for both. You either need to delete that IPv6 record, or correctly configure IPv6.

I have check. I dont have enabled IPv6 on my webserver.
this IP address 2a06:98c1:3120::8 is cloudflare where it is detected when I try to renew certificate. I dont know how to disable on claudflare.

Go to DNS. Edit (on right of listing) the AAAA record and and you should see a Red delete button.

there is no AAAA record on cloudflare.

So that IP belongs to Cloudflare you mean.
Use mxtool supertool and select AAAA lookup from the dropdown and add your domain, does it return a IPv6 address or does it error.

Also try Recheck Configuration do you see the line.
Default IPv6 address for virtual servers is

Also make sure DNS is disabled in each Virtualserver

I have check with MxToolbox, and I have IPv6.
I have disabled DNS on one Virtualserver, but I cant do it at all because I dont have all virtualservers through cloudflare.

Try IntoDNS. It will check the entire record and indicate problems.

ok, please advice. I dont know how to do it. ty

Server Configuration -> Suggest DNS Records

As I understand it, you host your DNS at Cloudflare, correct?

You’ll need to check the Cloudflare documentation for how to fix your DNS records. I’m not a Cloudflare expert (I’ve never used it). Someone here might be able to tell you how to do it, as I know there are Cloudflare users here, but your problem is not a Virtualmin problem based on all the comments you’ve made so far.

Just go there and put in the domain.

We already know what the problem is (they have an AAAA record, but aren’t actually offering a website on the IPv6 address it resolves to). As I understand it, there is no more troubleshooting of DNS to be done. The problem is understood, the solution is to remove that record. OP needs to go to Cloudflare and remove the record.

That’s fine, you only have to do it on the one virtual server that uses cloudflare.

I dont know how to disable IPv6 on cloudflare. I think its activated by default and this is the problem. Please advice what to do. ty