Execution of cgi scripts


I installed virtualmin on Ubuntu server 14.04, it’s working fine, but apache does not execute cgi or perl scripts. I tried everything, but it just shows scripts instead of executing them.

I realized that while trying to install OTRS, but later, I installed git for my server, and when I go to /git, it also shows me the script. Did I miss something that needs to be checked?

Thank you :slight_smile:


Hmm, are PHP scripts working properly? Or do those have the same problem as well, just displaying the script?

Also, if you look in Server Configuration -> Website Options, what is the “PHP Execution Mode” set to?


Yeah, php scripts are working fine (I have 1 owncloud instance), ruby as well (I just installed redmine).

PHP mode is FCGId, but I tried CGI wrapper and apache mod_php, same result :frowning:

Hmm, I’m wondering if the old “SetHandler” issue still exists… I doubt it, but it’s worth a try.

When you go to “Webmin -> Servers -> Apache Webserver -> Global Configuration -> Edit Config Files”, choose the file /etc/apache2/mods-available/php5.conf and click “Edit Directives in File”, do you see “SetHandler” directives in there? If so, try commenting them out.

No, it was already commented, mo problem there.

Ok, now I feel stupid… The module cgi was not enabled… I didn’t check because I thought it was by default, that’s the first thing I should have checked…