/etc/cron.daily report failing

Hi People,

This morning I found a Cron failure email as follows :-


postdrop: warning: uid=0: Illegal seek
sendmail: fatal: root(0): queue file write error

Checking with my best buddy Google the only answer seems to be that the max message size is too small. THat doesn’t seem to be the case in this instance.

Max message size is set to 20MB and the usual size of the logwatch email is always below 2MB.

I have checked numerous things including the size of the logs, and server statistics (loking for unusual activity) but nothing looks out of the norm. I have also done a lot of digging around but because that investigation might be flawed I wont mention it here because it might mislead.

Any suggestions would be very welcome.

Thanks for reading

CentOS Linux 5.8
Webmin version 1.585
Virtualmin version 3.92 Pro


Well, I’ve never run into that error before, so I’m not too sure what to offer there. I’m curious what this command shows though:

mailq | tail -1

That should show how many messages are currently in your mail queue.


Hi Eric,

Thanks for the thought.

Output from mailq | tail -1 …

– 128 Kbytes in 9 Requests.

Yeah that doesn’t seem unusual. I was curious if maybe there were a lot of messages in the queue.

I unfortunately don’t know what might cause that. I’m not sure that I’d be too concerned unless it were happening every day though.

Doing some Googling, it really does sound like the typical reason that error might occur are due to the max message size (as you mentioned).

You could always try making it larger, even if it seems like it’s already set pretty high – maybe something unusual is going on, and you’ll find out what if it’s able to send you a rather huge email :slight_smile:


Hi Eric,

Thanks, solved it.

I did actually try that earlier this morning, I made the max size to 30MB and ran cron job manually, got the same error.

For completeness I did it again and this time doubled it and it worked. The logwatch email was over 30MB !

Greylisting is running on this server and that part does look suspiciiously large. I will dig into that but at least I can see the problem now.

Thanks again.