Error when switch to php 7.0

Hello, i have install virtualmin on ubuntu 14.04.4 LTS. Installation is working find. And in the section service configuration -> php version there is 2 php version that allow me to select first is php5.5 and php7.0. But i will get 500 error if i switch to php7.0. And it still working find if i go to php5.5.

And found out in apache2 i have mudule php5 and php7.0 and only php5 is enable and i try to check on php7.0 module apache2 will error and respone ERROR: Module php5 is enabled - cannot proceed due to conflicts. It needs to be disabled first!

And i try uncheck the php5 module and check only php7.0 module and restart apache2 still reproduce error
pache2: Syntax error on line 140 of /etc/apache2/apache2.conf: Syntax error on line 2 of /etc/apache2/mods-enabled/php7.0.load: Cannot load /usr/lib/apache2/modules/ into server: /usr/lib/apache2/modules/ cannot open shared object file: No such file or directory

Node: i’m using php and apache2 with lastest version from ubuntu ppa

Again thank for the help and apologize for my English!

hi, php7 is still not stable that much however I think your scripts are not compatible with php7… did php5- not worked for you or something?

The php5 is really stable for me when using with virtualmmin But virtualmin will automate install php7 and configure for default of my virtual website. This why i’m not sure why virtualmin auto set php7 for default even it is not working anymore. Thank you!

HI, to my knowledge, virtualmin does install php5 automatically. I have to yet see php7 to be automatically installed by virtualmin. I would say check your apache logs or check your webapp if its support php7 - perhaps dont use php7 yet if there is no good reason for it.

Anyway. Now switch back to php5 and work like a charm! thank you