Error report ProFTPD FTP Server

Error in the new installation. Installed virtualmin in ubuntu 16.04 LTS
after successful installation , if starting proftpd getting the below error, please help to resolve the same. reinstalled and tried many times

Failed to start service :
Starting proftpd (via systemctl): proftpd.serviceJob for proftpd.service failed because the control process exited with error code. See “systemctl status proftpd.service” and “journalctl -xe” for details.
failed!

Take a look here and post result.?

https://www.virtualmin.com/node/53543#new

Thank you for your reply, i’m solved the issue by using the below comment , its from this thread , thanks for your support.

Hi Guys,

Instead of commenting out the TLS lines just add at top of the file LoadModule mod_tls.c and enjoy the benefits of SFTP.

The full /etc/proftpd/conf.d/virtualmin.conf file on Ubuntu 16.04 TLS will looks like bellow:

DefaultRoot ~

Enable TLS

LoadModule mod_tls.c
TLSEngine on
TLSRequired on
TLSRSACertificateFile /etc/ssl/certs/proftpd.crt
TLSRSACertificateKeyFile /etc/ssl/private/proftpd.key
TLSOptions NoCertRequest
TLSVerifyClient off
TLSLog /var/log/proftpd/tls.log

TLSSessionCache shm:/file=/var/run/proftpd/sesscache

VirtualHost for SFTP (FTP over SSH) port

LoadModule mod_sftp.c

<VirtualHost 0.0.0.0>
SFTPEngine on
SFTPLog /var/log/proftpd/sftp.log

Configure the server to listen on 2222 (openssh owns 22)

Port 2222

Configure the RSA and ECDSA host keys, using the same host key

files that OpenSSH uses.

SFTPHostKey /etc/proftpd/ssh_host_rsa_key
SFTPHostKey /etc/proftpd/ssh_host_ecdsa_key

Configure the file used for comparing authorized public keys of users.

SFTPAuthorizedUserKeys file:~/.sftp/authorized_keys

Enable compression

SFTPCompression delayed

More then FTP max logins, as there are more ways to authenticate

using SSH2.

MaxLoginAttempts 6

I hope this will help.

https://www.virtualmin.com/node/53455

Hari, that advice is correct, but you can also fix it with this command:

# virtualmin config-system --include ProFTPd