Error receiving email (Postfix)

Hi Guys,

Just set up virtualmin with postfix an a few virtual servers, but now I get some weird error when receiving email: (expanded from host[] said: 550 No Such User Here" (in reply to
RCPT TO command)

Why does it expand the correct adress into

The adress is present in virtual: harm.eendhoven

But somehow it keeps appending the wrong domain name…
Thanks a lot!


You may want to verify what your hostname is, using the “hostname” command – and then make sure that name is both:

  1. Setup in /etc/hosts

  2. Exists on the “mydestination” line of /etc/postfix/

If it gets out of sync, weird things can start occurring in email :slight_smile:


The hostname is server1, it’s in the /etc/hosts (short and fqdn) and exists as a mydestination in
Still the same error. It does translate in the username (harm.eendhoven) but it is expanded as being in the wrong domain.

It has been resolved! There was an masquerading option turned on which triggered this behaviour.

Only now I got a new problem… I host a few domains on this server, when I connect thorugh webmail there is no problem sending email. When I connect through Outlook however, the mails do disappear from Outlook, but it isn’t delivered to the external domain. When I try doing it manually through telnet I get a 554 relay access denied. Plz help.

You’ll need to take a look in the mail logs to see what’s going awry, there may be some error messages in them.

You’re probably getting relay access denied via telnet due to not authenticating – it wouldn’t allow just anyone to connect and send emails. Which is something you might wish to verify in Outlook, that it’s setup to authenticate outgoing email.


This is what the log says when I try do to it manually through telnet or through Outlook:

Nov 19 19:30:00 server1 postfix/smtpd[5077]: connect from[]
Nov 19 19:30:00 server1 postfix/smtpd[5077]: NOQUEUE: reject: RCPT from[]: 554 5.7.1 Relay access denied; proto=ESMTP helo=
Nov 19 19:30:02 server1 postfix/smtpd[5077]: disconnect from[]

How can I resolve this without setting it up as an open relay server?

It’s saying relay access denied – that’s the issue with enabling authentication for outgoing smtp that I mentioned above :slight_smile:

In Outlook will be a setting to make sure Outlook attempts to authenticate before sending any email. It’s often not enabled by default.


Indeed the smtp-verification did the trick, now the mail is completely up and running.
Thanks a million.