Error Processing Request: Problem with the SSL CA cert (path? access rights?)

Hi - I’m getting this message on my server right now which is causing some website functions not to work:

Error: Error Processing Request: Problem with the SSL CA cert (path? access rights?)

Recently, I had an issue with the disk space on my server being used up by log/email files being constantly generated in the /root/Maildir/new/ folder - actually, this still happens, eventhough i deleted the folder. (the folder just reappeared after deletion).

I’m not sure if the deletion of this folder caused this SSL CA cert issue to arise but thought i would mention it.

Anyway, does anyone know how i can resolve this?

John

Solution: https://www.virtualmin.com/node/35874#comment-142861

this didn’t work for me.

i also tried restarting apache - still no luck.

any other ideas?

Restart the entire server…

tried that, still no joy

The error itself seems to be affecting wordpress mostly as the error appears in the Dashboard area of my wordpress sites on this server as an RSS error, although strangely it doesn’t appear in all those sites, but most of them.

RSS Error: WP HTTP Error: Problem with the SSL CA cert (path? access rights?)

Howdy,

If it’s related to disk space, you may want to run this command to verify that you have enough:

df -h

If that appears normal – you mentioned that some website functions weren’t working. What’s an example of what’s not working? What is it you do to trigger that problem?

-Eric

it seems to have fixed itself - it may have been a delayed reaction to the solution ivanbg posted - seems like it took 24 hours after implementing his solution that it took effect - i did the same on another server and the same thing happened - it took about 24 hours to resolve - although it may just have fixed itself, not sure - thanks anyway.

I have same problem. Had try provided solution - no luck even after 24 hrs. Looks like Virtualmin bad update :\

Interact, Virtualmin doesn’t change the permissions on any SSL certificate paths.

The issue that was linked to is a problem with a CentOS package called NSS – there is a CentOS package bug where updating the nss packages can break the RPM database, and generate the error you’re seeing there.

Are you using CentOS?

If so, are you able to use yum to install other packages? Or does installing a package generate an error?

-Eric

I meant by auto-update done by Virtualmin which has installed NNS which contains bug.

Full server reboot solver problem in my case.