Error on 'Preview Website' on new server

Hi all,

I am upgrading to a new server, so have a brand new, fresh install of CentOS 6.2 and Virtualmin3.90.

I have restored three domains to the server using the excellent backup & restore features to transfer my domains across from the old server.

As I don’t yet have any DNS pointing to the new server, I am trying to use the ‘Preview Website’ function, but for all three domains, I just get:

Error: Connections to IP addresses not on this system are not allowed :

This is however the correct IP address and is the main IP for the system.

Obviously I am reticent to switch my DNS untilI I can see the sites running well on the new box.

Can anyone point me in the right direction for what might be causing this?

Thanks in advance,


OK - I have an idea as to what this might be.

On my new server, I ran a RDNS check, and sure enough, my provider has not updated their RDNS to point the IP address back to my hostname.

Does it make sense to think that Virtualmin is performing a check on the RDNS for the server’s IP address before allowing the “Preview website” CGI script to run, so that the script can’t be used to display websites on other servers, and throwing the error if the RDNS is not forward confirmed?

I’ve asked the ISP to update the RDNS, though of course I’ll have to wait for it to propagate, and in the meantime it would be good to get the thoughts of anyone here as to whether this is a likely solution.

OK - no, that wasn’t it. Those RDNS entries have propagated, and it hasn’t made any difference.

I’ve ploughed six hours into this now and am getting nowhere.

so if you go into Edit Virtual Server - Configurable settings - External IP address is then Same as real address enabled or in the field after it another IP.
Per haps you can play with that setting. Sounds like the old IP is in the system somewhere.

Hi Ronald,

Yes, “Same as real address” is enabled. I tried entering the same IP address in the field after it, that made no difference.

Thing is, the system does know its IP address, because when I set one of the virtual servers to be the default for the IP address, I can surf to it using the IP address no problem.

But I just can’t use the Preview Website function for the others :frowning:

Looking in var/webmin/miniserv.error, it seems that the:

“Error: Connections to IP addresses not on this system are not allowed”

is flanked on either side by

“Failed to initialize SSL connection”

None of the virtual servers has SSL enabled. Does this give anyone any ideas as to what this might be?

For anyone turning this up in search results in the future, Jamie was kind enough to respond to my bug filing with a very simple solution.

This problem is caused by the missing file:


Once I added my system’s ip addresses in there, line separated, the Preview Website immediately began to function as it should.