Error - No cookies

A client of mine is getting this error when trying to login to virtualmin:

Error - No cookies Your browser does not support cookies, which are required for this web server to work in session authentication mode

What could be the problem? Is there a place I can configure the cookies? Although it seems that for me it doesn’t use any cookies… odd…


Session authentication definitely uses cookies. :wink:

So, the client is unwilling to enable cookies? If so, you’ll need to switch Webmin over to traditional HTTP auth logins. Look in Webmin:Webmin:Webmin Configuration, and click on “Authentication”. Find the option labeled “Disable session authentication” and set it. Save it. You may also need to restart Webmin for the change to take effect or it may restart automatically when you save the change, I don’t recall.

Note that you lose the ability to do password timeouts, and several other nice security features.

ok i managed to track down the problem:
i created a login form on my site for logging in directly to virtualmin

[code:1]<form id="virtualmin" method="post" action="https://myserver.tld:10000/session_login.cgi">[/code:1]

it works fine with IE7, but firefox and safari seem to have problems and spit out that cookie error :frowning:

what am i doing wrong?