Error - mySQL Lib to be compiled and or linked in to the PHP engine

Operating system: CentOS Linux 7.9.2009

how to solve Fatal Error: ezSQL_mysql requires MySQL Lib to be compiled and or linked in to the PHP engine error on virtualmin ?

Trying to install PHP Vibe script on the virtual server all setup perfectly but getting this error Fatal Error: ezSQL_mysql requires MySQL Lib to be compiled and or linked in to the PHP engine


Hi, error message said it loud and clear…I think you are in wrong forum, ask developers of that script as error msg points you.

Hi, reached to script developers but they are saying that this error will be fixed from cpanel.

Virtualmin is open stuff, cpanel is not even close to anything virtualmin are not running cpanel perhaps you was not asking right questions towards developers

I asked them that we are using Virtualmin and Webmin trying to install your script on our virtual server but getting this error. they told us that this error will be fixed from your dashboard/server.

They also told us, If you were using Cpanel you would have fixed the problem with the help of this article. but here you are using a Webmin/Virtualmin in a dedicated server so we are only able to fix problems if in our script. but here is the problem with your server contact your server(hosting) provider it will help you.



I would assume that you’d need to install php-mysql package.

Refer to Virtualmin official guide on how to install additional PHP versions.

Hi, additional php versions already installed

Now open PHP information accordion and check if mysql extension is install.

it looks like mysql extension is installed, please see here

I would suggest checking if it is actually getting loaded for given virtual server by creating index-phpinfo.php small file with the following content:


… and opening it in your browser … if everything looks good, it’s not something we could assist you with. As this question should be asked on PHP Vibe community.

I think @Ilia meant


I’m pretty sure default Apache will barf on the short tag.



sorry, last time, I have checked phpinfo.php it looks like mysqli is off/disable.

Thanks, Richard for pointing out but the short tag is referred as <? while I mentioned <?php , only omitting closing tag, which is not mandatory in this case. :wink:

Okay. I thought there was a space in there after <?. Maybe it was lack of coffee on my part.


There was a space and I fixed it as you mentioned it.


1 Like

Okay, thanks. I was going to start looking for better coffee.


Thanks to all of you problem is solved by changing PHP Version.