Error installing VM on Cloud server

SYSTEM INFORMATION
OS type and version Almaalinux 8.5
Webmin version not got that far
Virtualmin version 7.0 RC7
Related packages SUGGESTED

@staff

I thought it better to start a new thread as this is a different error than I had before.

Clean, minimal install of Almalinux 8.5. Installing VM 7 RC7.

Error message as follows:

Installing Virtualmin 7 and all related packages [ERROR] Failed with error: 1
[ ✘ ]

[ERROR] Something went wrong. Exiting.
[ERROR] The last few log entries were:
tar-2:1.30-5.el8.x86_64
wbm-virtual-server-3:7.0.gpl-5.noarch
wbm-virtualmin-awstats-2:6.0-1.noarch
wbm-virtualmin-htpasswd-2:3.1-1.noarch
webmin-1.991-1.noarch
zlib-devel-1.2.11-18.el8_5.x86_64

Installing dependencies and system packages: Success.
Spin pid is: 79718
Error: Error downloading packages:
perl-Term-Spinner-Color-0.05-1.noarch: Cannot download, all mirrors were already tried without success

Installing Virtualmin 7 and all related packages: [2022-05-30 17:09:23 BST] [ERROR] Failed with error: 1
[2022-05-30 17:09:23 BST] [ERROR] Something went wrong. Exiting.
[2022-05-30 17:09:23 BST] [ERROR] The last few log entries were:

there is nothing following that line that says what the last few log entries were.

I may have broken the new repos while cleaning them up and working on Debian/Ubuntu.

I’ll try to fix it today.

Every time I installed 8.5 and ran dnf update the OS upgrades to 8.6. Can you comfirm what your version now?
[root@petos ~]# hostnamectl
Static hostname: petos.ml
Icon name: computer-vm
Chassis: vm
Machine ID: 33b02cebf4a14c99819b54b01f428365
Boot ID: 133516c3f3e747f18d91cf656f92b4b6
Virtualization: kvm
Operating System: AlmaLinux 8.6 (Sky Tiger)
CPE OS Name: cpe:/o:almalinux:almalinux:8::baseos
Kernel: Linux 4.18.0-372.9.1.el8.x86_64
Architecture: x86-64

Steve

@joe no worries I’ll try again tomorrow.

@stefan1959

I can’t do that tonight but I will do it tomorrow and let you know.

Thanks

Hi @stefan1959

Here is the info for that command:

[root@server3 ~]# hostnamectl
Static hostname: server3.xxx.xxx
Icon name: computer-vm
Chassis: vm
Machine ID: 061714cdfa784eed974b5b4cba940108
Boot ID: 306fe8c4d5124787abb7ea2917cffee8
Virtualization: kvm
Operating System: AlmaLinux 8.6 (Sky Tiger)
CPE OS Name: cpe:/o:almalinux:almalinux:8::baseos
Kernel: Linux 4.18.0-372.9.1.el8.x86_64
Architecture: x86-64

This issue has been fixed. It was related to the move of repos.

1 Like

That’s what dnf update does. Minor version changes of the OS are just regular updates.

Appreciate that @Joe

Just tried again and am gettinmg the same error. Any ideas are welcome. I’m using the download link in the other thread for RC7.

Thanks

Same error? You mean perl-Term-Spinner-Color won’t install? Really? I don’t see how.

Yes as in my original post i.e. the same error

Make sure you’re using the install script version I’ve linked in my News post about the beta release.

And, then do the following before installing:

dnf clean all

The package in the repo right now is definitely right. I just did a test install.

sure I’ll do that.

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.