Error: home is not a directory in /home/.....

Just installed Virtualmin 3.69 on existing FreeBSD 7.1/Webmin 1.470. When I run the FileManager module, I get this error "home is not a directory in /home/ebarns". This seems to be happening to all the domains that were imported from existing apache server.

Creating new domain works fine. Any clue?

Is that happening as the Virtual Server owner, or as the root user?

If you haven’t tried as root yet – does that work?

Also, does the directory it mentions exist? In your case, is there a “/home/ebarns” directory? If so, it’s not by chance a symlink, is it?
-Eric

The error happens as virtual owner. As a root, it opens in the ‘/’ root directory as it should.

Yes the directory exist. In FreeBSD by default /usr/home is symbolically linked as /home.

If the problem is with this link, it doesn’t explain why it works fine when new virtual is created instead of importing it.

There was just some discussion about issues with symbolic links. Some of the code in Virtualmin was being overly cautious in the case of links. I suspect this might be more of the same, but I’ll ask Jamie to confirm.

This looks like a Webmin bug - when /home is a symlink, the permissions granted in the File Manager module are incorrectly to the link rather than to the real directory. The quick fix is the edit each domains user’s file at /etc/webmin/file/$username.acl , and in the root= line change the path from /home to /usr/home

The alternate solution is to re-do the imports with the home directory being in /usr/home instead of /home. Virtualmin 3.70 will fix this properly.

That works.
Just installed virtualmin couple of days ago for the first time. Still trying out all it’s features.
Thanks for fix.