Error during installation

Hi

I need help in the installation of virtualmin. I am receiving the errors below

Checking for HTTP client...found /usr/bin/curl -s -O Checking for perl...found /usr/bin/perl Loading log4sh logging library... INFO - Started installation log in /root/virtualmin-install.log INFO - Checking for fully qualified hostname... INFO - Hostname OK: fully qualified as bonghome2.dyndns.org INFO - Installing serial number and license key into /etc/virtualmin-license INFO - Loading OS selection library... INFO - Download of http://software.virtualmin.com/lib/oschooser.pl Succeeded. INFO - Loading OS list... INFO - Download of http://software.virtualmin.com/lib/os_list.txt Succeeded. INFO - Operating system name: CentOS Linux INFO - Operating system version: 7.0.1406 INFO - Configuring package manager for CentOS Linux 7.0.1406... INFO - Disabling SELinux during installation... INFO - Download of http://software.virtualmin.com/gpl/rhel/7.0.1406/x86_64/virtualmin-release-latest.noarch.rpm Succeeded. INFO - Succeeded. INFO - Installing dependencies using command: /usr/bin/yum -y -d 2 install bind bind-utils caching-nameserver httpd postfix spamassassin procmail perl-DBD-Pg perl-DBD-MySQL quota iptables openssl python mailman subversion mysql mysql-server mysql-devel mariadb mariadb-server postgresql postgresql-server rh-postgresql rh-postgresql-server logrotate webalizer php php-xml php-gd php-imap php-mysql php-odbc php-pear php-pgsql php-snmp php-xmlrpc php-mbstring mod_perl mod_python cyrus-sasl dovecot spamassassin mod_dav_svn cyrus-sasl-gssapi mod_ssl ruby ruby-devel rubygems perl-XML-Simple perl-Crypt-SSLeay mlocate ...in progress, please wait... \Error: Package: mod_python-3.3.1-16.el6.x86_64 (epel) Requires: libpython2.6.so.1.0()(64bit) Error: Package: mod_python-3.3.1-16.el6.x86_64 (epel) Requires: python(abi) = 2.6 Installed: python-2.7.5-16.el7.x86_64 (@anaconda) python(abi) = 2.7 python(abi) = 2.7 Error: Package: mod_python-3.3.1-16.el6.x86_64 (epel) Requires: httpd-mmn = 20051115 Removing: httpd-2.4.6-18.el7.centos.x86_64 (@updates) httpd-mmn = 20120211 httpd-mmn = 20120211x8664 httpd-mmn = 20120211-x86-64 Updated By: 1:httpd-2.4.6-18.el7.centos.vm.1.x86_64 (virtualmin) httpd-mmn = 20120211-x86-64 httpd-mmn = 20120211x8664 httpd-mmn = 20120211 Available: httpd-2.4.6-17.el7.centos.1.x86_64 (base) httpd-mmn = 20120211x8664 httpd-mmn = 20120211-x86-64 httpd-mmn = 20120211 Available: 1:httpd-2.4.6-17.el7.centos.centos.1.vm.x86_64 (virtualmin) httpd-mmn = 20120211-x86-64 httpd-mmn = 20120211x8664 httpd-mmn = 20120211 Available: 1:httpd-2.4.6-18.el7.centos.vm.x86_64 (virtualmin) httpd-mmn = 20120211-x86-64 httpd-mmn = 20120211x8664 httpd-mmn = 20120211 /usr/bin/yum -y -d 2 install bind bind-utils caching-nameserver httpd postfix spamassassin procmail perl-DBD-Pg perl-DBD-MySQL quota iptables openssl python mailman subversion mysql mysql-server mysql-devel mariadb mariadb-server postgresql postgresql-server rh-postgresql rh-postgresql-server logrotate webalizer php php-xml php-gd php-imap php-mysql php-odbc php-pear php-pgsql php-snmp php-xmlrpc php-mbstring mod_perl mod_python cyrus-sasl dovecot spamassassin mod_dav_svn cyrus-sasl-gssapi mod_ssl ruby ruby-devel rubygems perl-XML-Simple perl-Crypt-SSLeay mlocate failed. Error (if any): 0

Displaying the last 15 lines of /root/virtualmin-install.log to help troubleshoot this problem:
–> Processing Dependency: systemtap-sdt-devel for package: 4:perl-devel-5.16.3-283.el7.x86_64
–> Processing Dependency: perl(ExtUtils::ParseXS) for package: 4:perl-devel-5.16.3-283.el7.x86_64
–> Processing Dependency: libdb-devel for package: 4:perl-devel-5.16.3-283.el7.x86_64
–> Running transaction check
—> Package libdb-devel.x86_64 0:5.3.21-17.el7_0.1 will be installed
—> Package mod_python.x86_64 0:3.3.1-16.el6 will be installed
–> Processing Dependency: python(abi) = 2.6 for package: mod_python-3.3.1-16.el6.x86_64
–> Processing Dependency: httpd-mmn = 20051115 for package: mod_python-3.3.1-16.el6.x86_64
–> Processing Dependency: libpython2.6.so.1.0()(64bit) for package: mod_python-3.3.1-16.el6.x86_64
—> Package perl-Business-ISBN-Data.noarch 0:20120719.001-2.el7 will be installed
—> Package perl-ExtUtils-ParseXS.noarch 1:3.18-2.el7 will be installed
—> Package systemtap-sdt-devel.x86_64 0:2.4-14.el7 will be installed
–> Finished Dependency Resolution
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

FATAL - Fatal Error Occurred: Something went wrong during installation: 0
FATAL - Cannot continue installation.
FATAL - Attempting to remove virtualmin repository configuration, so the installation can be
FATAL - re-attempted after any problems have been resolved.
warning: /etc/yum.repos.d/virtualmin.repo saved as /etc/yum.repos.d/virtualmin.repo.rpmsave
FATAL - Removing temporary directory and files.
FATAL - If you are unsure of what went wrong, you may wish to review the log
FATAL - in /root/virtualmin-install.log

Howdy,

It looks like you have at least one third party repository enabled (EPEL).

Third party repositories can cause problems, especially on CentOS 7. My suggestion would be to disable any software repositories not enabled by default, and then to attempt the Virtualmin installation again.

-Eric