Error during installation script - no localhost in /etc/hosts

I’ve tried to install virtualmin via sh script in my vps, but i get this error:
“There is no localhost entry in /etc/hosts”

How can i solve?
in etc/hosts i’ve:
“94.141.xx.xx vps-00xx”



ps (sorry for xx)


Sounds like you need to add a localhost entry to your /etc/hosts file… that would look something like this: localhost

i’ve just added that line, is correct?

Once you add that line, re-run the installer and see if that error goes away :slight_smile:

All, just installed… i’ve only 1 error: i’ve tried to send an email to a domain installed on vps and i’ve received this error from google:
“Technical details of permanent failure:
Google tried to deliver your message, but it was rejected by the recipient domain. We recommend contacting the other email provider for further information about the cause of this error. The error that the other server returned was: 553 553 sorry, that domain isn’t allowed to be relayed thru this MTA (#5.7.1) (state 14).”

What can i do or check? Thanks

Sorry, everything is ok, just i made an error in “/etc/hosts”… i’ve typed, for error, instead of… now i’ve changed to correct one, but have i to re-install virtualmin?

Nope, no need to reinstall – you should be all set once you correct the entry in /etc/hosts.