error connecting to

I moved my server to another building and all was well prior to the move. I had a problem with websites after the move, but it had to do with a config issue and my IP address had changed. That is solved, the websites work fine now.

Problem is the mail. I am getting mail into the mail queue but it is just sitting there. In the logs, I have found this:

Oct 20 11:02:09 pixelmountainstudio postfix/smtp[28806]: connect to[]: Connection refused (port 25)
Oct 20 11:02:09 pixelmountainstudio postfix/smtp[28807]: connect to[]: Connection refused (port 25)
Oct 20 11:02:09 pixelmountainstudio postfix/smtp[28810]: 16DF012D848F: to=info@removed,[]:25, delay=681, delays=681/0.01/0.12/0.1, dsn=4.0.0, status=deferred (host[] said: 421-Connection dropped because your IP is a suspected spam source. 421-Please retry delivery later. 421-If you believe this may be in error you may go here: 421 (in reply to DATA command))
Oct 20 11:02:12 pixelmountainstudio postfix/smtp[28807]: connect to[]: No route to host (port 25)

I see that pixelmountainstudio is there, but it should be I have checked the hostname and it was fine. I also removed the hostname from

I am at a loss. I really need mail to be up and running.




If you go into System Settings -> Re-Check Config, does it notice any unusual problems?


I did the re-check config and it reports that all is well.

Thanks for the quick response.

What output do you receive if you run the command “postconf -n”?

And the line that shows your public IP address in /etc/hosts, what does that look like?

Is any email being delivered to or from your server, or does all mail seem to be having the problems you’re showing above?


Some mail is getting through now. I will check the logs again and see what is up.

I get what looks to be the postfix config. Looks normal to me.

The IP address is correct in the hosts file.

Everything is looking better. I will send a few more test emails and see what happens.

The mail queue still has 97 messages in it. I guess those won’t go anywhere as I have flushed the queue and they stay there.

Hi again,

Same person, different user name on a different computer.

Some of my clients are not able to connect to the outgoing mail server. Again, nothing should have changed. Looks like some mail is getting in and out, but not for everyone.

Should I delete the queued messages from yesterday? Will that help?


You’re welcome to delete the queued messages – it might help to know what problems are current, and what’s just left over from earlier issues.

When you say that some clients can’t connect to the mail server – what problems are they having exactly? What error messages do they get?

Also, it might help to get their IP address, and then see if you can find a corresponding entry for their connection attempt in the mail logs.


Thanks Eric,

The error message is that they cannot connect to the outgoing mail server. I haven’t checked the logs lately, but will do that now.

Thanks again.


Some things you’d want to check are what hostname they’re using to connect to, as well as what port they’re trying to connect to. Something could be awry with the DNS for the hostname they’re using, or one of the ports might not be accessible for some reason.

It’s also possible that the DNS for the hostname they’re connecting to has the old IP address cached… though that would typically clear up after a day or two.


Cleared the queue, and according to the logs, the clients are able to connect to the server and are getting mail, but this one client in particular cannot send. The error gives a hex number and says to check the settings. I can send and receive without a problem, both to that client and to my gmail account.

Another problem is that the same client collects his mail on his Blackberry, and is unable to send through that. Now, his settings are for his Blackberry provider, not my server. That makes no sense either.

Ok, so I thought I was using my server to send mail to, but I wasn’t. I was using my ISP. So I switched to my server and this is what I get. From what I can gather, this message is different than what my client is getting.

An error occurred while sending mail. The mail server responded: 5.7.1 Relay access denied. Please check the message recipient and try again.

Sounds like a setting, but which one?

They are connecting to the right hostname, and are using the right port. I double checked my router and it has all the ports open that I need.

Also double checked the DNS and it all seems right too. Could their router be caching the old IP? Should I get them to restart their router?

Getting a “relay access denied” error suggests that your desktop client (such as Outlook) isn’t authenticating when sending an outgoing message.

Some desktop clients (and Outlook in particular) don’t default to doing that.

What you would need to do is go into your settings, and enable authentication when sending an Outgoing SMTP message.

As far as DNS goes – if there’s a DNS problem, restarting their router would only help if it’s the router caching the entry. It could be worth a try… though after 2 days, it seems unlikely to be a DNS cache problem.


Yes, you were right, it was an authentication issue. My mail sent without a problem. One issue down.

Client still can’t send. Makes no sense if I can send why can’t they send? Nothing should have changed on their end. I will get them to double check the ports.

Thanks again for the help.


Stupid me, it was a port issue. Thanks Eric for all the help!