ERROR: Can't connect to clamd: No such file or directory ***FIXED***

I am trying to setup a fresh install of Vitrualmin with Ubuntu 12.04 x64 on a VPS from DigitalOcean but I keep coming up against the same problem.

The install goes fine and I can log into the control panel and run through the Post-Installation Wizard, but then errors at the ClamAV section with the following:

A problem occurred testing the ClamAV server scanner :
ERROR: Can’t connect to clamd: No such file or directory

----------- SCAN SUMMARY -----------
Infected files: 0
Time: 0.000 sec (0 m 0 s)

I have search this and other forums and tried various things but to no avail. I have re-built about three time to see if there is something I am doing wrong but this come back again and again.

All help great appreciated.


What do these two commands show:

dpkg -l clamav ps auxw | grep clamav


dpkg -l clamav
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Description
ii clamav 0.97.6+dfsg-1u anti-virus utility for Unix - command-line i

ps auxw | grep clamav
clamav 16604 0.0 0.4 44048 2028 ? Ss Feb07 0:46 /usr/bin/freshclam -d --quiet
root 28053 0.0 0.1 9384 892 pts/0 S+ 15:41 0:00 grep --color=auto clamav


I have worked out what was going on here. The VPS had been created without a swap partition so every time that clamav was starting it filled the ram.
I added a swap file as it is on an SSD and everything flew into life.
Thanks for your help.