Error: Cannot retrieve repository metadata (repomd.xml) for repository: virtualmin-bleed

Not sure if this is virtualmin related, would be awesome if someone can help me with it though :slight_smile:

Keep in mind that im a linux noob, so you might need to give me command to execute if you want me to post anything back :stuck_out_tongue:

So i have a Centos VPS, and i tried to install java, and get:

[root@server1 ~]# yum install java
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile

Hmm, well, it does appear that the URL it’s using for repo metadata doesn’t exist.

If you look in /etc/yum.repos.d, do you see a file there for the Virtualmin bleed repo? If so, can you paste in it’s contents?

Thanks!

-Eric

Oh, actually, I see what the issue is… the Virtualmin Bleed repo is, at this point, designed for CentOS 5.

CentOS 6 has newer software available than what’s currently in the Bleed repo.

Which isn’t to say that it won’t at some point have software in it for CentOS 6, but with that being such a new distro, there hasn’t currently been a need to provide that.

-Eric

[virtualmin-bleed]name=Red Hat Enterprise $releasever - $basearch - Virtualmin Bleeding Edge baseurl=http://software.virtualmin.com/bleed/rhel/$releasever/$basearch/ enabled=1 gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-virtualmin gpgcheck=1

Yeah I think I’m using centos 6. I see.

I’m not entirely sure what that means, but is there anything I can do to fix it? :frowning:

Well, I guess I’m saying there’s no reason to use the bleed repository on CentOS 6… there’s no packages in it available to your distro. Your distro has newer packages available within it than are in the bleed repo.

My recommendation would simply be to disable the bleed repository.

-Eric

Oh i see. That makes sense.

emm, small question… emm how would i go about doing that? :S

Well, one way would be to edit the .repo file for the bleed repo… and set “enabled=0”.

You could also just delete the .repo file, or rename it so that it doesn’t end with .repo… for example, you could rename it so that the filename ends with .old or .disabled.

-Eric

yey, it worked!

Thanks Eric. :slight_smile: