Error - Access denied for ...

hello,

First, to explain about me, I am a seasoned programmer but a newbie for the sysadmin mambo-jumbo.

Second , I got promoted CTO of the company, and amongst the new tasks , there is server administration.

We are running with AWZ as host for our servers; I can access webmin in all the servers but 1.

I tried all the passwords combo I had, so the access denied for myip-address.

I found on the web a wayto reset the password :

/usr/share/webmin/changepass.pl /etc/webmin /etc/webmin admin foo

but still not work.

I checked etc/shadow … webmin was not created.

So I am screaming for help, I need to login webmin for that server (I decided to enable mysql replication, and there are some tasks I prefer to do from GUI, I prefer to use xshell for important task.

I am sure the subject have been covered already, so my apologies for putting it again, and sincere condoleances for my broken english (I am french, working in Phuket thailand).

Thanks in advance for any help.

auto fixed, as stated even if I am a seasoned programmer (37 years into it), I am a newbie about sysadmin.

/usr/share/webmin/changepass.pl /etc/webmin /etc/webmin admin foo

was obviously wrong, because even if I logged as root, changepass.pl was not root

sudo /usr/share/webmin/changepass.pl /etc/webmin admin foo

did the job