Enable PHP Short TAgs by Default for new Virtual Hosts


I have php short_tags enabled in my /etc/php5/apache2/php.ini but when I create a new VirtualHost in VirtualMin, the /home/{site}/etc/php.ini has short_tags as Off.

To save me the time of having to edit each local php.ini each time, is there a way I can tell VirtualMin to, by default, set new VirtualHosts to enable short tags?

I’ve looked through the ‘server templates’ and didn’t see anything in there.

Many thanks in advance


On Ubuntu/Debian, Virtualmin uses /etc/php/cgi/php.ini for the template.

Try editing that particular php.ini file, and see if that provides you with the settings you want when you create a new Virtual Server.


Awesome, worked a treat thank you.

(mine is at /etc/php5/cgi/php.ini if anyone else reads this)