enable php interpreter on default website (ip address)

I’m trying to install Zabbix on my Centos 7 / PHP 7 / Virtualmin platform.

Everything goes well up until I need to access my server https://IP_ADDRESS/zabbix

I get garbage writting:

[T_ZBX_STR, O_NO, null, null, ‘isset({enter})’, _(‘Username’)], ‘password’ => [T_ZBX_STR, O_OPT, null, null, ‘isset({enter})’], ‘sessionid’ => [T_ZBX_STR, O_OPT, null, null, null], ‘reconnect’ => [T_ZBX_INT, O_OPT, P_SYS|P_ACT, BETWEEN(0, 65535), null], ‘enter’ => [T_ZBX_STR, O_OPT, P_SYS, null, null], ‘autologin’ => [T_ZBX_INT, O_OPT, null,

Now I’ve tracked it down to the fact that the php is not being executed so I know it has something to do with Apache, the problem is I have no options in Virtualmin to modify the “default” site.

How do I enable PHP for the default site so I can access the webpage?

Thank you


To begin, did you try to put .php file in your public_html folder containing:

What log files have to say? Is there any error?

There are no errors in the logs, the issue is that Zabbix wants to use the default site which is not in use, it overrides the DocumentRoot “/var/www/html” and uses its own installation (probably an alias), the issue is that PHP is working for all my virtual sites but not for the default one.

Php info page is blank on the default site where Zabbix resides.

So it wont execute it, just looking on how to add a directive so that the default site will execute. Plenty of solutions for ubuntu (https://www.zabbix.com/forum/showthread.php?t=55326) but nothing for centos.



Virtualmin uses /home/username/public_html/ and not /var/www/html. Are you sure you are setting up things correctly?

Here is my configuration, the 3 sites I have work fine, but as you can see the “default site” is pointing to /var/www/html. Zabbix is installed under /usr/share/zabbix (with an entry in /etc/httpd/conf.d/zabbix.conf) of Alias /zabbix /usr/share/zabbix). If I put in any site /zabbix it shows the same raw php code.


I also just want to add that the default website is not available as a drop down on the virtualmin tab so there is no way for me to specify anything about php.


In case anyone else comes across this:

Since this is on a vmware server I created a new vm with minimal resources, fresh install of centos and zabbix and everything worked out of the gate.