Email usernames "username.domain" incorrect, probably configuration problem.

I’m sure this is just a configuration problem on my part, so don’t laugh too hard at me.

I have create a virtual domain, lets call it for this case. I set the default username to pcm2a. When I go into mail and ftp users I see an entry like this:

Name IMAP/FTP Login Real Name pcm2a pcm2a
So far so good. Next I create a new account for my fiances email, lets call her melissa (since that’s her name). Now I see an additional entry like this:

Name IMAP/FTP Login Real Name melissa melissa.pcm2a Melissa

Now you can see my problem, what kind of login is “melissa.pcm2a”! I would expect that to be “” since I have the default email setting of username.domain picked.

How can I get all of my virtual domains to use usernamme.domain instead of username.primary_username?



Ahh, interesting :slight_smile:

Well, you should be able to tweak that from within System Settings -> Server Templates -> Default -> Mail for Domain – the option you want is called “Format for usernames that include domain”.


Right, that was the first place I went to try to fix this issue. The default is already set to “username.domain”. The other selections are just other configurations of the same thing, like “username@domain”, “username_domain”, etc.

I assuming changing that will just change the username from melissa.pcm2a to melissa@pcm2a, which wouldn’t really solve anything.

I could rename my primary use to “”, but that seems crazy.

What is the login to anyone elses accounts (besides the primary) for a vhost? Is everyone else getting “somename”.“” or is everyone else getting the same results as me?

I’m having the same problem. I don’t see the solution to this on this thread. I would like my usernames to be what I decide (given they are available on the system) and not have the .domain or @domain appended at all.

It seems that this was easy to configure before but somehow I can’t find the solution.


It sounds like you may want to look in System Settings -> Module Config -> Defaults for New Domains.

The option “Include domain name in usernames?” I think is what you’re after.

To configure how they look when the domain name is used – you can look in System Settings -> Server Templates -> Default -> Mail for Domain. You’d want to tweak “Format for usernames that include domain”.