Email stuck in outbox for some not all users, postfix restart works, but then happens again later!

OS type and version: Centos 6.10 (Final)
Webmin version: 1.981
Virtualmin version: 6.17
Postfix Version: 2.6.6

I have this server for years, as you can see! There are many email accounts on it. Its worked fine for years. Server has not been updated recently for this issue to occur (dont think there are any more updates for it).

2 days ago a customer reported emails being stuck in their outbox in Outlook. They can receive email OK.

I renewed the SSL but that was not the issue.

I restarted Postfix and it all started working again.

A few hours later, it happened again. Restarted postfix and all started working.

Yesterday a different customer had the issue. BUT it was only one of their email accounts, someone working at home, so their own IP address. The rest of their email accounts on other IPs worked fine.

I restarted postfix and it worked again.

I have had to put the postfix restart in a cron every 30 minutes until this is resolved.

I cant see any errors anywhere, postfix is running, no errors in maillog. In fact, the users with issues show as connecting to postfix/smptd in maillog. Although I think it may be slightly different:

Log when issue occurs:
Oct 6 10:29:34 ac4 postfix/smtpd[30581]: connect from host12.34.56.78.btcentralplus.com[12.34.56.78]
Oct 6 10:31:02 ac4 postfix/smtpd[30581]: lost connection after AUTH from host12.34.56.78.btcentralplus.com[12.34.56.78]
Oct 6 10:31:02 ac4 postfix/smtpd[30581]: disconnect from host12.34.56.78.btcentralplus.com[12.34.56.78]

Log after postfix restart:
Oct 6 10:35:13 ac4 postfix/smtpd[11221]: connect from host12.34.56.78.btcentralplus.com[12.34.56.78]
Oct 6 10:35:23 ac4 postfix/smtpd[11221]: EBBC5389D39: client=host12.34.56.78.btcentralplus.com[12.34.56.78], sasl_method=LOGIN,
Oct 6 10:35:26 ac4 postfix/smtpd[11221]: disconnect from host12.34.56.78.btcentralplus.com[12.34.56.78]

Could it be related to these users network, so some network issue in the local area for it to only affect a few people? But then why would postfix restart fix it. All very strange.

Does anyone have ideas how to solve the problem?

Thanks

That was end of life a year ago. (November 30th, 2020)

I wouldn’t be the least bit surprised that lack of updates and support is causing that issue.

Yes I am aware of that, its not simple to just flick a switch and update, so legacy systems will need to run for some time, until users emails migrate and upgrade their websites.

I wouldn’t be the least bit surprised that lack of updates and support is causing that issue.” - this confuses me a bit, because if something works and you do not change it, how could it just break on its own? I would expect issues when you do do updates, not when you just leave something operate as it has been.