Email issue - Using Postfix

So, my server is domain.com. I have been using Zohomail for off-site mail. I get email at killjoyhk@domain.com through Zohomail just fine, unless it originates from my domain.com server itself. Is there any way that I can have postfix automatically not attempt to push my killjoyhk mail to the LOCAL box, but rather to push it to my zohomail.com box instead?

Howdy,

That can happen if the email feature is enabled for your domain(s).

You can correct that by going into Edit Virtual Server -> Enabled Features, and disabling the “Mail for Domain” feature.

-Eric