Email forwarding sends 50 emails than errors

SYSTEM INFORMATION
OS type and version Rocky Linux 9.2
Webmin version 2.021
Virtualmin version 7.7
Related packages SUGGESTED

Base install, nothing special. First time using ROcky Linux, and for first time using server for mail accounts, migrating all accounts over from cPanel server.

Seems any forwarded I set up, it will send 50 copies of the e-mail to the listed forward address, then fail out, and thus local mailbox won’t have the message eiter.

At first I thought it was an issue that the account was imported from a cPanel backup, but then went and manually set up a blank account for a test domain, same things, 50 copies and crap out.

I didn’t find anything about it when searching here, but hope someone knows.

Been using VM for 8 years now, but this is the first time I had to have mail on the server. Figure worse case, will pay for VM, (will be saving $45/month on cpanel license anyhow when all is moved :wink:

You have a forward to one email address and it send out 50 emails of the email you send to it?

I don’t think GPL or pro version would make any difference to mail, only for support.

Monitor the mail log when you send the email and look at the postfix mail aliases for any weird entry.

This sounds really weird. Why 50 and where has this been set. Don’t think it has anything to do with cPanel unless some postfix configuration was brought over during setup. It sounds like it has been something done during setting up a new account.

You say “nothing special” but that could mean a lot! What exactly was done to the “base install” or this would be a common problem for many.

Even stranger this is happening on a new VS “test domain”. Assuming all the “default” templates are being used - is there even a setting in the mail default mail account template to set forwards? I don’t recall having seen it.

Are these 50 forwards being sent and received? I’m back to the question why 50. as well as why any. Also they are stopping for a reason, if that is due to a error it should be in a log somewhere.

My guess you hit the “max number of recipients per message” limit.

you can change it in webmin > servers > postfix > delivery rates.

Now go buy VM pro and feed the devs … hahaha

Michael

So there is that option? (that took some finding unless one has a need for it)
But it still would have involved a deliberate change from “basic install” wouldn’t it?

google claims that 50 is the default, and on my test server, default_destination_recipient_limit did not exist in /etc/postfix/main.cf until I set it to something other than 50.

I too did not know postfix had that setting :slight_smile:

I do hope that is not another bit of lunacy from the folk at Google!

I have clients who regularly need to send out emails to all their users (sales/marketing/security alerts/etc) and would exceed this recipient list limit.

I can’t believe the limit has been adopted by Postfix or Virtualmin as a default. (I assume that normally the excess are just temporarily differed/queued and would eventually get delivered.)

I have of course just gone in to each server and fixed this oversight.

Still does not explain why it failed on or above 50 with no logged error.

@stefan1959 Correct, the forwarding is set up to just send to one e-mail address (my personal one), and when mail comes in I get 50 copies, and then the server errors out (probably a max limit, thank goodness for my personal mailbox sake :wink: and then on the server because of that the message doesn’t end up in the mailbox account there.

@Stegan It most likely is stopping at 50 as probably programmed somewhere is a limit on how many (which is good, else who knows how many it will install)

By base install, I was meaning that no additional tools other that the default ones selected during install were added. Yeah, my first thought was some setting that got pulled in from the imported mail accounts glitched, but before going and trying to find it, I went and set up the VM account with a domain name, created an e-mail account, and told it to forward as well, and same thing, each incoming mail ends up in some loop till it maxes out.

@Shirehosting the problem is, some e-mail need to send to up to 6 people (ie. support@domain.com forwards to 6 of us, so first one to get it can reply) So if I set it for a max 6, then all the forwarders that only need to forward to me, I’d still get 6 copies :wink:

BTW, to everyone, thanks for the quick replies! It is much appropriated. I’ll be investigating this more after my afternoon meeting and will look for the logs and post anything relevant I can find here.

Don’t change that! You want a limit on emails to a recipient, but you don’t want to use that as a fix for a broken forward. Fix the forward!

So are you saying that “max number of recipients per message” does NOT prevent the number of recipients receiving a message. So a client email can SEND to 50 plus recipients without some of them being delayed or worse blocked? - and could be better described as something else.

Broken forward ? I don’t see where. Broken in what way? and how can that be on a vanilla email account that has not been “imported” just created on a new VS

The only loop that I can see is if the email is not delivered and it ends up being requeued. but even that when failing would surely produce an error?

Check you mail queue it all clear, else you will get another burst.

Does the forward area look ok?

Does the mail alias area in postfix look ok. it should have the entries created by virtualmin

No 50 is the default number from postfix.

No exactly the opposite.

This is from the postfix doco.

default_destination_recipient_limit (default: 50)

The default maximal number of recipients per message delivery. This is the default limit for delivery via the lmtp(8), pipe(8), smtp(8) and virtual(8) delivery agents.

Setting this parameter to a value of 1 affects email deliveries as follows:

    It changes the meaning of the corresponding per-destination concurrency limit, from concurrency of deliveries to the same domain into concurrency of deliveries to the same recipient. Different recipients are delivered in parallel, subject to the process limits specified in master.cf.

    It changes the meaning of the corresponding per-destination rate delay, from the delay between deliveries to the same domain into the delay between deliveries to the same recipient. Again, different recipients are delivered in parallel, subject to the process limits specified in master.cf.

    It changes the meaning of other corresponding per-destination settings in a similar manner, from settings for delivery to the same domain into settings for delivery to the same recipient. 

Use transport_destination_recipient_limit to specify a transport-specific override, where transport is the master.cf name of the message delivery transport.

But you will notice that setting some functions to the number 1 changes the behavior entirely. Eg setting this to 20 or 50 is not the same as setting it to 1 as per above.

Michael

This is a forwarding issue, nothing to do with the limits above.

Thanks for that.
So it is the use of language by Postfix that is poor.
It really should be the “max number of messages per recipient” so that if someone attempts to send their message to the same recipient more than 50 times it will only be sent 50 thereby preventing the recipient’s mailbox being filled with junk (so a good thing to limit to 50 or even less). and it will not affect the number of different recipients receiving the message.

Yes sorry for the topic diversion.
On a new install adding a new user the default Mail forwarding is:
Screenshot 2023-08-09 102055
So no forwarding (as the OP has stated a new test domain new user) there should be nothing set here which sort of questions the forwarding being the problem. I don’t know anywhere else a forward can be set except inside a specific email in Usermin (and that is not involved here)

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.