Edit Virtual Server save error


I’m very new on this system, so i start from beginning:)

  1. background:
    I have webmin installed to server and virtualmin plugin added to webmin (at least I think it’s the case - like I said - new user!). I am the root of server, that hosts 50+ websites (and growing) via Virtualmin as virtual hosts.

  2. set ups:
    I have disabled some “systems” from “Create Virtual Server” pakcages and add some, but that not also the case. Main point - I have disabled the mailbox createn - virtual hosts are not having e-mails in my server.

  3. problem:
    When I want to edit/change some virtual server stuff (some thing, like password, in “Configurable settings” section or add/remove features in “Enabled features” section) and hit the save button, I receive followin error:
    “Failed to modify server : Missing or invalid mail username prefix”
    No error code to search by, no more info, no help/info in web just that error. And of course, no save as well. I can delete server and create new one, but c’mon, do I really have to do that for just simple password change!?

4: tryed:
I have tryed to do everything in (only changable section there) “Configurable settings” section: change names, removed them (leave blank the input field) etc. nothing. I have reviewed the package I have to create these; allowed plugins/features; server settings that are allowed for hosts - nothing. I even tried to search solution in webmin part and tried to disable all mail things I could find no help there.

5: request:
If anyone have even slight idea what is wrong or why this happnes, it would be nice to let me know so that I can fix it.

Thank you.

What do the domains in question have set in the “Edit virtual server -> Configurable settings : Mailbox name suffix” field?

I get this error message when I empty out the “mailbox name suffix” and try to save changes. You might just try entering some appropriate text there, maybe the domain name. It doesn’t really matter what you enter there if you don’t use mailbox users in your domains. But apparently the field must not be empty.


You were right - “Edit virtual server -> Configurable settings : Mailbox name suffix” this field must contain domain with domain extension.

so if I create, for example, new virtual host with custom name(s), Mailbox name suffix field is going nuts on that custom name - I guess it’s related to ftp username or something like that.

So “so-called” work around would be following:

  • choose server you want to edit from leftside dropdown box.
  • click on “Edit virtual server”
  • open “Configurable settings” tab/section
  • and change “Mailbox name suffix” field to domain.com|net|org|eu|etc.

Thanks, Locutus, You gave me that idea :wink:

You’re welcome, and glad to have helped. :slight_smile:

Additionally, you might want to check out some options that determine the automatic choice of “Mailbox name suffix” in newly created domains:

System Settings -> Virtualmin Configuration ->Defaults for new domains : Include domain name in usernames? / Domain name style in username.

System Settings -> Server Templates -> Mail for Domain : Format for usernames that include domain

Those might help avoid this problem in the future.

We do not use virtualmin for email but anytime we try to make changes we get

Failed to modify server : Missing or invalid mail username prefix


We’re happy to help – however, could you start a new Forum post? This particular thread is pretty old. Also, include as many details as you can about the problem. Thanks!