E-Mail cant be connected to Clients

Hey together,
I´ve added 2 top Server with 1 extra email on each.
They work as promised, so sending and recieving through the webinterface is no problem.

But however it is simply not possible to connect any client like Outlook or thunderbird with the adresses.

Greetings and thx for help so far

Please, if someone has an idea i would be very thankful to hear it.

with this small of an amount of information. Do you have a Dovecot server running? Have you enabled mail for the domain in VIrtualmin? Have you checked the firewall on the server to make sure pop and imap are open? What happens if you try to telnet in to the IMAP or POP ports from outside the server?

To add on what cruiskeen already said is that some mail clients will refuse or have problem to connect to mail server if the connection is not secure e.g. you dont have valid and not self signed SSL cert.

Sorry, for answering so late, the certs are now running. I had some Issues with the SSL option for domains.

Sadly I now have a new problem, all the big hosters like Google,gmx.de etc. mark the emails sent from my server as spam because of some PTR Issues. How Can i fix this.
I already set an reverse DNS to my hostname. The mx record is set like:

The hoster of my VPS has created the mx records, no chance to edit them.

Here is my E-Mail Header:

Delivered-To: bla@gmail.com
Received: by with SMTP id 123csp2488229ion;
Tue, 15 Dec 2015 06:43:29 -0800 (PST)
X-Received: by with SMTP id 133mr5606536wmw.36.1450190609220;
Tue, 15 Dec 2015 06:43:29 -0800 (PST)
Return-Path: mail@domain1.de
Received: from host.exampleserver.net (host.exampleserver.net. [example IP])
by mx.google.com with ESMTP id 18si33220355wmi.68.2015.
for bla@gmail.com;
Tue, 15 Dec 2015 06:43:29 -0800 (PST)
Received-SPF: neutral (google.com: example IP is neither permitted nor denied by best guess record for domain of mail@domain1.de) client-ip=example IP;
Authentication-Results: mx.google.com;
spf=neutral (google.com: example IP is neither permitted nor denied by best guess record for domain of mail@domain1.de) smtp.mailfrom=mail@domain1.de
Received: from [] (aftr-95-222-27-129.unity-media.net [USER IP])
by host.exampleserver.net (Postfix) with ESMTPSA id B29C7B6A0089
for bla@gmail.com; Tue, 15 Dec 2015 15:43:28 +0100 (CET)
To: bla@gmail.com
From: User mail@domain1.de
Subject: test
Message-ID: 5670270A.5020606@domain1.de
Date: Tue, 15 Dec 2015 15:43:22 +0100
User-Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:38.0) Gecko/20100101
MIME-Version: 1.0
Content-Type: text/plain; charset=utf-8; format=flowed
Content-Transfer-Encoding: 7bit

You need to set rDNS with your IP and PTR records in DNS.

OK, so far so good. I created an rDNS entry on the ISP level.
But because it is still not working I assume that i have to create a ptr record in bind DNS.

Could you tell me what I have to enter in the mask, because i dont get it. What shoul i put in the field: Value ?

If you have IP “” and you set rDNS “niceptr.domain.tld” then in your DNS you must select PTR records -> Record name: niceptr -> Cache time: leave it as it is -> Reverse address: -> Record comment: leave it empty.

But you said your ISP, if you mean on real ISP and not hosting company or data-center then i’m not sure if you can set rDNS because i dont know for single case where ISP allows rDNS.

Only the real owner of IP range can set rDNS. Now some hosting companies have this option enabled in their control panel (like SolusVM) or you must open a ticket with them and ask to set rDNS. When it comes to ISP they are the owners of your IP and so they are the only one who can change rDNS. In case you are trying to sort your server located at home/office and you didnt contact your ISP (and they will reject this request 99.99%) you actually didnt set your rDNS.

Ok maybe i am missunderstanding you, but my hosting company of my vserver gives me the option to set an reverse DNS in the webinterface. I now set the PTR record.

Till now nothing changed, i still get these PTR Error messages from big hsoters like gmail oder gmx.


Is it possible that your provider hasn’t set that up yet, or the DNS is cached?

You may want to try performing the lookup yourself to see if the record exists.


i´ve now waited a week to see if the changes take a while to get noticed by gmx, but sadly it didnt.

It is maybe a bit too much to ask for, but can someone of you guys give me personal help via email? I am feeling very uncomfortable to post screenshots here with server details.


For Gmail and others you dont need to add anything to your DNS its enough to set rDNS. If you did on fresh IP without previous rDNS it should take from few minutes to 3-4 hours max. to propagate and in case you are changing rDNS from old to new one then can take 24 hours but not more than 48.
So there is a lot of online tools to check if you have rDNS, use any of them and if it fails that means your host didnt set or there is some other problem but not sure if this have anything to do with your DNS.