Dual Server setup - Dedicated Email Server - SSL Problems with email server & T'bird, Insecure connections.

Dedicated Email server, from Virtualmin > System Info > Status
Servers=Postfix, Dovecot IMAP POP, SSH, ClamAV & SpamAssassin.
No SSL enabled

Virtualmin > Server Configuration > Select a domain > Manage SSL Certificate
is NOT AVAILABLE (Allows certificate copy to Webmin, Usemin, Dovecot and Postfix.
There appears to be no easy way to manage certificates, consequently the dedicated email server does not support IMAP or POP3 secure login by Thunderbird from Virtualmin.

On a Dedicated Web server these features are available evidently because the Apache Server is enabled for the websites, and for some reason the Managment of SSL Certificates is available.

Why can’t we use SSL on a dedicated Email Server with Pop and Imap Thunderbird? That is where it is needed to prevent a host of spam… I assume this is possible, but do not know how to configure it.

Perhaps someone can advise further. I’d like to know how to configure Virtualmin/Webmin for secure SSL/TLS or STARTTLS connections for incoming and outgoing SMTP server, with encryption of login passwords to work with Thunderbird client IMAP and POP. 995 and 993 are open. 80 & 443 are closed.

Thank you.

Virtualmin > System Info > Status
Servers=Postfix, Dovecot IMAP POP, --SSH Server --, ClamAV & SpamAssassin.

So the SSH Server is running
delete this -->(there, but in other places it is not enabled.) <–got confused.
but SSL does not seem to be available…See post above.

Under Virtualmin > System Settings > Features and Plugins SSL Website is not checked.
(This is not a WEB server, it is an EMAIL server.)

What is checked is Admin, Home Directory, Mail for Domain, Not Apache Website, Not SSL Website, Spam, Virus, Webmin Login, Nothing else.

Enable SSL for Your Domain

Use the following instructions to enable SSL encryption for your domain:

Log into Virtualmin.
Select a domain from the drop-down menu in the left-hand navigation pane. Your main domain is selected by default when you first login to Virtualmin. This is the domain for which you will enable SSL encryption.

Click the Edit Virtual Server link.
Click the Enabled features section to expand it.
Select SSL website enabled? This assumes you already have selected Apache website enabled?.
Click the Save Virtual Server button. A page will display a warning that SSL cannot be enabled for more than one domain on the IP address. Click the Yes, Modify Virtual Server button to override and conclude with the SSL setup,

===
That’s all fine and it works when there is a webserver, but this is an EMAIL server and we don’t have Apache enabled so the option “Enable SSL website?” (besides it is not SSL website but SSL email) does not show up under “Enabled Options” and is not available.

Peter at TPN Solutions solved the problem for me. Perhaps I will be able to figure out what he did eventually, if so I will post the information,but It looks like he enabled the Apache server as a first step.

Thankyou Peter.