Dropdown and List Virtual Servers not working!


No real problems with Virtualmin for years, and when was one, we solved it fast with your help. But this doesn’t make any sense, today I created the 51 domain. So, I’m sure as a consequence, the dropdown on the left with the domains is not working anymore, and when I type a domain (do not want to type the name of the domains anywhere, by the way! possibly cause… hmm I don’t have to remember all?) in the field and clicking the button doesn’t do nothing.

And there is more. Said to myself > go list 'em! But the same and here on List Virtual Servers is a message “There are too many virtual servers on your system to display on this page.” The search is working at least in this page.

Now, 51 domains is a ridiculous small number. And even if I have >500 I would certainly need to see them, who came up with this ideea not to display the domains? How can one make use of the software… if the its very object can’t be displayed.

Pls solve this problem, there should be some sort of pagination, but it would be best if the dropdown would work again.

Didn’t do anything else, so I am pretty sure it is related.

Thank you and pls help me solve this problem.

Traditionally there should be a setting somewhere regarding pagination, listings, filters and so on, is there sometjing like that in Webmin/Virtualmin configuration that I missed?


I think I know your problem (it got me too!):

Go to system settings >> vm configuration >> user interface settings and there’s an option “Maximum number of domains to display”


OMG that solved it. Why the hell didn’t saw that? Got to find an ophthalmologist :slight_smile: