Download Virtualmin GPL

Where can I download Virtualmin GPL? I tried the Webmin site and all I could find were plug-ins for virtualmin.

Wow! Am I blind? I went back to the webmin site and there was the link, right on the front page. I can’t believe I was so blind.


The above link is giving the friendly reply;

404 Not Found
The requested URL /download/virtualmin/virtual-server-2.604.wbm.gz was not found on this server.
Apache/2.0.53 (Fedora) Server at Port 80

In fact, the GPL edition has disappeared from the map entirely. As in all roads lead to Rome, all links to the GPL version lead to a 404.

It is not uncommon for GPL software to go commercial. In fact, this is really cool. But it’s becoming too common that a GPL edition vanishes at the same time a commercial edition appears. Makes one frown.

I would not be moaning about this if I used Virtualmin for commercial purposes. I would happily pay the fee. But I don’t, and I’m not in the ISP or hosting business.

Excuse my dust.

In any event, does anyone have a working link to the GPL edition?

Hey Carlos,

Don’t worry, Virtualmin GPL is still being actively maintained. You’ve just followed a (very) old link. Our pace of development is very rapid, so links to specific versions of the package are gonna go stale very quickly.

You can always find the latest GPL version here:

The download link is in the upper right corner. You may note that the version available there is the very same version number we are distributing in the Professional product (minus a few Professional-only features)–GPL is in very active development, just like Professional. We want to keep our Open Source users happy, too.

And feel free to talk to us here in the forums about any problems you might have getting it running or using it once installed. We’re all happy to talk about both versions of the product–though you should generally mention that you’re using GPL, so we won’t assume you’re using our defaults and our to set things up.

generates a 404 rerror

Hey William,

Argh. More Sourceforge-related issues. SourceForge websites broke sometime in the past couple of days, leading to being down for some time…Jamie moved it to our dedicated server, but it appears the download links are wonky.

I’ll ask him to take a look. Thanks for the heads up.

Should be back now …

nods works now…thanks!