Downgrade PHP 5.3 to 5.2 or Fix error with FastCGI server

I have migrated a server to a new server and using Virtualmin. Love it! but it installed Php 5.3 as the default php. I need to be able to run php 5.2 with Zend. so I added Php 5.2 and 5.4 to my list ad it see both php;s but when it runs PHP 5.2 it has to run it as CGI or FCGID and I get these errors:
(104)Connection reset by peer: mod_fcgid: error reading data from FastCGI server
Premature end of script headers: index.php

Now I know its not my Script itself. and I have looked EVERwhere I could to find a resolutuion.

But is there a fix to this? AND/OR How can I downgrade the default PHP to 5.2

any suggestions please…

thanks