Dovecot SMTP user authorization fails after upgrade Squeezy to Wheezy

Hello,

I was performing an upgrade from Debian Squeezy to Wheezy for a few hours - step by step over your excellent guide: http://www.virtualmin.com/documentation/system/os/debian-squeeze-to-wheezy-distupgrade

Everything works fine except Dovecot’s SMTP server authentication. I’m getting error 535 (authentication failed) for each user. Strange for me is that IMAP authentication works fine. The username login format is set to “username@domain”.

I’ve tried few variations of username and also checked configuration via Virtualmin / Webmin and it is the same as before in Squeeze.

This is just a test upgrade, the production server is still running on Squeeze VPS and test upgrade I tried on the clone of that VPS. So everything is same except IP address.

Thanks for help and suggestions.

Best regards, Nikos

Ok, so easy fix is to edit /etc/default/saslauthd

  1. Change START=yes
  2. set OPTIONS="-m /var/spool/postfix/var/run/saslauthd -r"

Nikos, thanks for this follow-up info!!

You are welcome!

But after many attempts of upgrading Squeeze to Wheezy with Virtualmin, I decided to try another way, which is batch backup of all virtuals via virtualmin and then batch recovery on a clean installation of Virtualmin with Wheezy.

The reason is that I didn’t reach 100% working solution. It was a fight with old and new configs, which some of them were neccessary to manualy modify. I finished in state where virtuals are unable to run PHP scripts.

I hope I’ll let you know, if the batch recovery is the simplier way, because I don’t have any extra or custom configuration of my Virtualmin.

Thanks to Virtualmin team anyway!