[Dovecot] Pop3 login failed!


I’m currently testing my virtualmin pro package on a newly installed server. I have added one domain for testing, but I can’t seem to login with pop3. This is the error listed:

May 30 21:52:11 hosting dovecot: chdir(/home/achterheide.be/homes/filip.vandenbulck) failed with uid 501: Permission denied
May 30 21:52:11 hosting pop3-login: Login: filip.vandenbulck.achterheide.be [[::ffff:]]
May 30 21:52:11 hosting dovecot: child 4170 (pop3) returned error 89

Any idea’s?

While i’m here anyways, is there any way to change the . between the username and domain for pop3/ftp logins?


Filip Van den Bulck

Hey Filip,

You didn’t mention what OS/version/arch you’re on.

The permissions denied error indicates you have an older version of Dovecot–if I know the OS (and it’s a supported OS) I can make sure new packages go into our repository.

Yes, the separator in usernames is configurable in Server Template under the "Mail for domain" section. The option is labeled "Format for usernames that include domain".

If you’re thinking @ is a better choice, I’d recommend reading the FAQ about it. There are quite a few incompatibilities with other systems when using @ in usernames (and you may need to alter the configuration of saslauthd).


Virtualmin system info:

Operating system CentOS Linux 4.5
Perl version 5.008005
Path to Perl /usr/bin/perl
Postfix version 2.2.10
Mail injection command /usr/lib/sendmail -t
BIND version 9.2.4
Apache version 2.0.53
PHP version 4
Webalizer version 2.01-10
Logrotate version 3.7.1
MySQL version 4.1.20
ProFTPd version 1.210
SpamAssasssin version 3.1.8
ClamAV version 0.88.4
Dovecot IMAP/POP3 Server Version 0.99.11

I was planning on using a + or - as indicator, like our cpanel uses now. That way we don’t need to change our logins and passes in email and ftp clients!

Greetz and thanks!

Problem solved!

After updating the dovecot program it worked perfect!

Thanks Joe!