Dovecot misses notify_init()


I just switched from Plesk to Virtualmin on a new vServer setup (Debian 5, Kernel 2.6.9-023stab052.4-smp).

I have some issues with dovecot and apache, my log files were filled with “too many open files” messages, I changed the max file count and those messages are gone (at least for now).

But in my mai.err, I still get messages like:

dovecot: IMAP(domainname): inotify_init() failed: Function not implemented

I tried to google a solution but had no luck, does anyone have a solution for me?

Thanks in advance!


Googling that particular error message, I see this bug report:

It looks like that version of Dovecot expects a newer kernel version… whereas, the kernel you have installed there is a bit on the older side.

Do you have an option to use a newer kernel with your server?

Debian 5 normally ships with 2.6.26. It looks like you’d need at least 2.6.13 to solve that particular inotify error.

The kernel you have there, 2.6.9, was released way back in 2004 – so that’s somewhat aging now :slight_smile:


Thanks for your answer, it seems like I cannot change the kernel module because it’s only a virtual server and my host won’t change it…

Is there any workaround I could try?

Sorry, I’m not aware of a workaround for what you’re seeing.

The tools provided by your distribution expect certain features to be available in the kernel in order to function properly.

However, with your provider only offering an old version of the kernel, the features you require aren’t available.

Personally, I’d recommend complaining to them that the kernel they’re offering you is 7 years old, and that current tools require a more recent kernel :slight_smile:

If they don’t offer you a more recent kernel, your options would be to either manually recompile Dovecot without inotify support, or to switch providers. If it comes to that, I’d suggest switching providers :slight_smile: