Dovecot errors - again

Hi Guys

I have yet another dovecot error as shown below.

Its come about after I restarted the box following some updates.
I have had the issue before and have posted in other threads.

The error message and the relevant lines are shown below. I’m posting this now before trying any fixes, but will try commenting out various bits to see what happens.

One point: Is that may have some bearing is that its possible that this dovecot conf has been copied over from a previous box, after reinstalling os and using vmin backups to reinstate. I dont actually know know if thats true or significant or not. Anyway I’m grateful for any input as to why this is happening.

doveconf: Warning: /etc/dovecot/dovecot.conf line 297: Global setting ssl_cert won’t change the setting inside an earlier filter at /etc/dovecot/dovecot.conf line 143 (if this is intentional, avoid this warning by moving the global setting before /etc/dovecot/dovecot.conf line 143)
doveconf: Warning: /etc/dovecot/dovecot.conf line 298: Global setting ssl_key won’t change the setting inside an earlier filter at /etc/dovecot/dovecot.conf line 144 (if this is intentional, avoid this warning by moving the global setting before /etc/dovecot/dovecot.conf line 144)
doveconf: Warning: /etc/dovecot/dovecot.conf line 299: Global setting ssl_key won’t change the setting inside an earlier filter at /etc/dovecot/dovecot.conf line 144 (if this is intentional, avoid this warning by moving the global setting before /etc/dovecot/dovecot.conf line 144)
doveconf: Fatal: Error in configuration file /etc/dovecot/dovecot.conf line 301: Unexpected ‘}’

143:	local_name domain1.com {
144:	ssl_cert = </home/domain1.com/ssl.cert
145:	ssl_key = </home/domain1.com/ssl.key
146:	}
	
	
287:	local_name domain2.com {
288:	ssl_cert = </home/domain2com/ssl.combined
289:	ssl_key = </home/domain2com/ssl.key
290:	  #ssl_ca = </home/domain2com/ssl.ca
291:	}
292:	local_name www.domain2.com {
293:	ssl_cert = </home/domain2com/ssl.combined
294:	#  ssl_ca = </home/domain2com/ssl.ca
295:	    ssl_key = </home/domain2com/ssl.key
296:	}
297:	ssl_cert = </home/domain2com/ssl.combined
298:	ssl_key = </home/domain2com/ssl.key
299:	ssl_key = </home/domain2com/ssl.key
300:	  #ssl_ca = </home/domain2com/ssl.ca
301:	}
302:	ssl_cert = </home/domain2com/ssl.combined
303:	ssl_key = </home/domain2com/ssl.key
304:	ssl_key = </home/domain2com/ssl.key
305:	  #ssl_ca = </home/domain2com/ssl.ca
306:	}
307:	
308:	ssl_cert = </home/domain2com/ssl.combined
309:	ssl_key = </home/domain2com/ssl.key
310:	ssl_key = </home/domain2com/ssl.key
311:	  #ssl_ca = </home/domain2com/ssl.ca
312:	}

Hi,

We need to know how dovecot.conf file looked before? If it’s on a backup file, it would be interesting to have that backup up to understand an issue.

This is covered in the release notes for Webmin 1.955: Webmin 1.955 released

Please read the note and follow the instructions for fixing your Dovecot config.

thanks @Ilia and @Joe for replies.
Ilia - I checked the dovecot.conf and it isnt based on the old config.
Joe - yes that fixed it. I’m pretty sure it was after LE cert autoupdate. I’ve had it happen before, but webmn ver. is up to date so it begs the question why is it still happening.

Thanks again
l.

I don’t know what else to try. I tried with commented ssl_ca, using different indent, with containing different kind of duplicates and not – all the time it works correctly for me and the config is not broken as in your initial post.

The only thing I can think of that happened on your side is that Webmin hasn’t been restarted as designed.

You may want to run manually:

/etc/webmin/restart

What distro was that?