Domains using non-default IP don't deliver emails when sent from scripts such as contact forms, need help...

I’m new to Virtualmin and Webmin, and I recently migrated four working websites that have a unique IP and SSL certificate to my server. After doing so I discovered that any forms on these websites, such as a contact form, no longer deliver email messages as they should.

Someone mentioned that this is a known and common issue with Apache configurations in Virtualmin/Webmin but didn’t offer a solution or any further explanation. Can anyone help me? Thank you!

Howdy,

Hmm, I’m not entirely certain what might cause that, but I suspect the logs could point us in the right direction.

What do you see in the Apache logs, $HOME/logs/error_log – as well as the email logs, /var/log/maillog or /var/log/mail.log, when trying to send an email from your contact forms?

-Eric

Thanks for the reply Eric.

I was able to deliver a message successfully to the email address gordon@.com (I’ve omitted the actual domains), but when I tried to send the same message, through the same system/script, to spencerhill@.com it didn’t work. Both emails are on separate domains, mine is the spencer* and it’s a Google Apps account.

“Jun 21 20:01:01 localhost postfix/smtp[7471]: 26B2A801FB: to=<gordon@.com>, relay=smtp.secureserver.net[72.167.238.201]:25, delay=1.2, delays=0.06/0.01/0.61/0.55, dsn=2.0.0, status=sent (250 ok: Message 1787251816 accepted)
Jun 21 20:01:01 localhost postfix/qmgr[1269]: 26B2A801FB: removed
Jun 21 20:12:11 localhost postfix/qmgr[1269]: 783B7801F4: from=qey62jn2@www.theportlandco.com, size=1015, nrcpt=1 (queue active)
Jun 21 20:12:32 localhost postfix/smtp[9306]: connect to test.com[50.23.225.49]:25: Connection timed out
Jun 21 20:12:32 localhost postfix/smtp[9306]: 783B7801F4: to=test@test.com, relay=none, delay=109716, delays=109695/0.02/21/0, dsn=4.4.1, status=deferred (connect to test.com[50.23.225.49]:25: Connection timed out)
Jun 21 20:13:08 localhost postfix/pickup[32361]: DF0B8801FB: uid=1088 from=
Jun 21 20:13:08 localhost postfix/cleanup[9434]: DF0B8801FB: message-id=f821556c9ad7651db48a325a088dfc96@www.woodburncompanystores.com
Jun 21 20:13:08 localhost postfix/qmgr[1269]: DF0B8801FB: from=qey62jn2@www.theportlandco.com, size=764, nrcpt=1 (queue active)
Jun 21 20:13:08 localhost postfix/error[9435]: DF0B8801FB: to=<spencerhill@
.com>, relay=none, delay=0.04, delays=0.02/0.01/0/0.01, dsn=5.0.0, status=bounced (User unknown in virtual alias table)”

So it appears that mail IS being delivered from all domains and IP’s on the server. However, it’s NOT being delivered to some addresses. For example, I submitted a contact form that emailed my Google Apps account, but not my private email server.

Any thoughts?