Domain name for outbound mail.

Hi Guys,

I would like the outbound mail from our server be domain.tld rather than host.tld. Also the "help" for the setting "What domain to use in outbound mail" in postfix configuration recommends this.

"You specify the domain that appears in mail that is posted on this machine. The default configuration of Postfix is to use the local machine name, hostname.
Unless you are running a really small site, you probably want to change that into domainname, which defaults to the parent domain of the machine name."

But if I change this setting to “Use domainname” I get “status=bounced (User unknown in virtual alias table)” when sending mail to a local user. I guess there are some other settings that I have to change to get this to work, unfortunately I can’t “play around” to test all setting as our server is “live” and are hosting many domains, therefor I need to get the settings right at once.
I have not done many changes to the original postfix install done when installing Virtualmin Pro, and I don’t think I have the right knowledge to “fix” this, hopefully some of you guys can point me in the direction on how and what I have to do to get this to work.

Regards,
Leif

Howdy Leif,

Actually, the help is wrong on this point. "host" is better than "domain" on a virtual hosting machine. So, relax and enjoy knowing that things are fine. :wink:

Hi Joe,

Ok… Yes I actually do "relax", the server is running just fine, but when trying to figure out the best configs for spam-fighting I ran into this setting again, and thought that changing this to domain was a good thing, I also thought that mails sent from our customer domains accounts would show their domain as sending host in mail headers by changing this.

But you are of course right… why change things that are working fine!

I think I will post another question regarding spam fighting. Or do you know/have any links to documents for “best defaults” for Postfix and SpamAssassin on how to stop spam, backscatter mails, forged addresses etc, I did look at your link regarding backscatter mail, but I don’t know how to add this to header and/or body checks.

Regards,
Leif