Domain and subdomain for FTP user

Hello, I installed Virtualmin, created Domain, then subdomain. Then went to my Domain and
Edit Mail and FTP Users > Add a user to this server > entered details and
in Other user permissions added Allowed directories and added Granted access to directories and database.
But then I connect thourgh FTP the user cannot see sobdomains directories. What should I change that this new user can connect to Domain and all it’s subdomains through FTP client.


I’d suggest using the “Create a Website Access User” on the right side of the Edit Mail and FTP Users screen. That’s a special FTP user who has rights to all the web directories for a Virtual Server (and it’s Sub-Servers).


Yes I did “Create a Website Access User” also, but in FTP window I just see folders STATS and .USERMIN. That’s it.

But when Domain is created virtualmin automaticaly creates admin user for this Domain.
With this user logged in throught FTP I see all domains and subdomains :frowning:

I use Virtualmin version 3.84.gpl GPL

It sounds like your system is setup to restrict that user to their home directory, $HOME/public_html.

You could try one of two things –

  • Rather than restricting users to their home directory, you could instead restrict them to the Virtual Servers home directory. That’s all configurable in Limits and Validation -> FTP Directory Restrictions.

  • You could change this users homedir to be $HOME rather than $HOME/public_html. That would allow them to browse to all the Virtual Servers.


First of all thank you for your replies.

Yes, i have tried to change parameters in FTP Directory Restrictions but unsuccessfuly. Option “All virtual servers - Virtual server’s home directory” does not work. Error message “Failed to save FTP directory restrictions : The virtual server’s home directory option cannot be selected unless the restriction applies to a specific server, in row 1” Then I did this procedure for “Only server” but my users just see STATS directory, able to browse and nothing more.

By the way FTP Directory Restrictions settings are for limiting access for domain administrator and for FTP users because of ability to see all directories :slight_smile:

For your second solutions, I have’nt such option in user editing “Quota and home directory settings” Options “Main website directory” and “Website subdirectory” are visible. If I understood correctly we are talking about this place.

There is nothing special for my Virtualmin install, it’s merely default options. Just using strukcture user@domain.tld

Then I did this procedure for “Only server” but my users just see STATS directory, able to browse and nothing more.

Well, when the user logs in – they would, by default, be located in $HOME/public_html. In order to see the other directories, they’d first need to browse to the parent directory ($HOME). Once they’re in $HOME, they should be able to browse to all the various domains in that account.

Are you by chance able to get to the parent directory?


I understand, but I can not get higher directory by FileZilla. If I login with administrator of domain I see everything I need. Maybe this is a bug in software.

Can you post a screenshot of your “FTP Directory Restrictions” screen?

The behavior you’re seeing isn’t the default… by default, all FTP users can browse the entire filesystem.


Try a different FTP client. Auto FTP Manager - - works great for us.

This is default config. I have tried differen options but result is the same. User can not see subdomains.
If I create user in subdomain he sees this subdomain. Subdomains are added in allowed directories in user settings. My system is Centos 5.5 64 bit by the way.

This is default config

By default, users can browse anywhere on the filesystem. If that’s not the behavior you’re seeing, something changed from the default :slight_smile:

Oh, actually – the “Active” checkbox isn’t set on the screenshot you posted.

So, nothing should be preventing a user from going to the previous directory.

It might be a good idea to try the suggestion made by adam0718, and try a different FTP client, as you should be able to browse the entire filesystem.