Domain Alias Problem?

I just recently purchased two domains. I now have them seutp as aliases of my “primary” domain. However mail sent to the aliases does NOT get routed to the primary. I would like to get routed to How do i accomplish this?


Make sure that in Edit Virtual Server -> Enabled Features, “Mail for Domain” is enabled. If that’s not enabled, no mail for that alias would be accepted.

Once it is enabled, you’ll be able to see in “Edit Mail Aliases” for your new domain that email is being directed to your primary domain.


enabling mail on a domain alias is NOT an available option.

So which options are you seeing for that domain alias?

And what if you log in as root and look, does that help?

Mail for Domain is capable of being an option for aliases, but there may be something preventing you from seeing it…


i do all of my work as root…the option isn’t there…i have not been able to find the setting anywhere to allow it. The only options are to enable a website and setup a dns zone.

Do you perhaps have the mail feature turned off on the System Settings -> Features and Plugins page?

nopers i have mail enabled globally as i have two domains doing mail locally. I had to tinker with it b ut i finally got domain aliases with mail enabled. However that caused other issues. I use Google apps for 4 of my domains. the problem is i cannot have a mailbox enabled loclaly or the mail gets routed to those local boxes irregardless of the mx settings. since i have no local mx records for the local machine this is a problem as i wanted to use one of the domains for smart hosting. I wound up having to remove all local mailboxes for those 4 domains and use a 5th domain as the smarthostone that does not use google apps). I have done quite a bit os custom bind work to get things working…but it’s not ideal yet. I would like for virt to pay atention to the mx records and NOT route mail to any local user accounts so i can properly smarthost.

Actually for the domain using google aps i have to disable mail in virt but then manually build the mx records in bind because of hte mail redirection issue i described above.

So in this case where mail is being delivered locally even though you have MX records pointing to Google, do you have the “mail for domain” feature enabled? When delivery is to elsewhere, it should not be enabled … and you will need to add the appropriate MX records manually.

question one…yes

Ok so this behavior is by design…:slight_smile:

Yes, that is expected. You don’t want to enable the “mail for domain” feature unless you are having email delivered locally.