Does virtualmin support Ubuntu 22.04 and rhel 9?

There should be absolutely no issues with awstats on Ubuntu 22.04.

What issues do you have? What is the output of awstats --version command on your Ubuntu 22.04 server?

image

That’s not awstats. And webalizer is no longer part of our default configuration (even if it were available), so I’m not sure why this is showing up at all.

It was fixed on the latest Virtualmin Config patches in main.

what about CentoS 9

I just tried the latest installer mentioned above on RHEL9 and it crashed:

Error:
Problem: conflicting requests

  • nothing provides perl-Geo-IP needed by awstats-7.8-7.el9.noarch
    Installing dependencies and system packages: [2022-08-02 17:42:21 ACST] [ERROR] Failed with error: 1
    [2022-08-02 17:42:21 ACST] [ERROR] Something went wrong. Exiting.

From bugzilla, apparently GEO-IP is EOL which may affect perl-Geo-IP.

Perhaps remove Awstats from the install script?

I actually installed on RHEL9 about 2 weeks ago and it didn’t crash. I did have problems with LetsEncrypt however, it would say it was successful for both the host system and Virt hosts , but neither actually worked according to the web browser.

I deleted that server to try again today unfortunately.

1 Like

@Joe and I are discussing how to deal with these kind of breakages. If you urgently need to install Virtualmin 7 with beta installer on RHEL 9, you can do it using this devel version of install.sh script.

Thanks for that script, it worked well.
However, both during the Wizard and later manually, applying a LE certificate reports as successful, but the padlock on the URL bar still only sees the local certificate.

Close and reopen your browser.

Closed Firefox, cleared all cookies using Ccleaner, restarted Firefox - still no LE certificate.

Do you have SSL website feature enabled (on Edit Virtual Server page) for the virtual server in question? It seems that your request to your virtual server falls back to a default (first one found on Apache config) VirtualHost.

Yes.

Turns out that I had to go Server Config, SSL Certificates, then select “Copy SSL Certificate to Services”.

That is new, it used to be automatic - which personally I prefer.

Nothing has changed recently in this area. The Copy SSL Certificate to Services is to make the selected domain the default certificate for those services, and should not matter if you are talking to the server using the name of that domain. Website, Webmin, Usermin, all automatically use the right certificate if you connect using the name of that domain.

Also, can everybody please stop responding with new problems? Please create new topics with new problems. This has nothing to do with the original question (or any of the other dozen questions in this thread…it’s absolute chaos).

1 Like

Sooooo, is Ubuntu 22 a go?

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.