document root

I just setup my new server with Debian 4.0,a and Virtualmin Pro. the server is setup as server1.mydomain.com. The DNS appears to have automatically registered mydomain.com upon install, and I have setup the nameservers for www.mydomain.com with my domain registrar. When I go to www.mydomain.com, I see the Apache2 test page (it actually redirects to it at www.mydomain.com/apache2-default/). From what I know of Apache2 (which is very little), I think that this is the webroot for my server. How do I access this, as it is not setup as a virtual server?

as far as i have experienced it, the IP of your server points to /var/www/html which is the default Apache server

when you create the first virtualserver/domain it will be placed in the /home directory.

The /var/www/html directory becomes "obsolete" and all further domains are placed in the /home directory.
It makes sense to me to "forget" about the /var directory and create your most important domain first, as when some strange errors would occur then this domain will show up in the browser.

EDIT: However, I didn’t just point the nameservers at the registrar.
I pointed the A record to the server and made 2 extra A records to point to my nameserver IP’s

Post edited by: ronald, at: 2008/02/16 10:40<br><br>Post edited by: ronald, at: 2008/02/16 11:08

Thanks for the quick reply-

That is what I thought that I understood as well, but when I attempted to create a virtual server for the domain that my server is setup with, the DNS kept pointing to the /var/www/html directore, not the /home/mydomain folder. Any ideas? or am I not able to create a virtual server for the account domain that the server is setup on?

if you are behind a NAT/router than you need to change something.
virtualmin->system settings->module config->Default IP address for DNS records…fill in the IP
in VM GPL it is called "other settings"

The documentation on this in the wiki is quite thorough if I didn’t make any sense. It was difficult for me too (and still is, lol)

I have setup my server with the main domain as well so that is surely possible.

Thanks again. That seemed to do the trick. Now however, I am having some issues with emails. When I created the virtual server, I created a user (user1) for the account. When I try to send emails to this user (user1@mydomain.com) however, I get a rejected notice saying that no such user exists. So I tried to send an email from the usermin of this user, and it went through as user1@server1.mydomain.com. I then tried replying to this address, and recieved the following error:[code:1]The mail server could not deliver mail to user1@server1.mydomain.com. The account or domain may not exist, they may be blacklisted, or missing the proper dns entries.[/code:1]

I then tried to create an email only account on this VS (user2), and tried to send an email to it (user2@mydomain.com), and again recieved the no such user exists error message. I then again tried sending a message via usermin, and the message came from user2.user1@server1.mydomain.com. and when I tried replying to this address, I got the above error again.

Any suggestions as to what is going on?

mail is a bit tricky. By default Postfix would work properly.
I had some email troubles in the beginning for my domain. But I solved this by solving dns issues and have the zone file records for the domain correct.
Then I made a new mailbox and all mail went through.
It seems you might have some dns issues as well.

i used http://intodns.com and also http://www.squish.net/dnscheck/ to make sure the domain was correctly setup and resolved properly.

at http://member.dnsstuff.com/pages/tools.php is a tool for email testing and more.

So I finally got around to fixing BIND, and I have run the test, and the only error I get on IntoDNS is that the DNS is recursive (which I don’t think should cause any email issues). Any ideas RE the email issues that I am still having?