DNS setup is not working

Although I tried to follow everything I found on this site, website doesn’t work :frowning:

I followed these steps and waited over 48h but still:

in my registrar Namecheap I registered 2 nameservers:
ns1.mysite.com 11.111.111.11
ns2.mysite.com 22.222.222.22

I then did a transfer to own host with same values as above still in Namecheap.

Next, in virtualmin under mysite.com that already worked fine with a simple A record (just for the record :slight_smile:

I followed Virtualmin’s tutorial:
“you’ll want to log into Virtualmin, select your “example.com” domain, click Server Configuration -> DNS Records, and create a new “A - IPv4 Address” record for ns1.example.com and ns2.example.com.”

It asked for ip v4 too, so I inputed the same values for each one as I did in namecheap:
ns1.mysite.com 11.111.111.11
ns2.mysite.com 22.222.222.22

Now when I enter the command:
host -t NS mysite.com

It resolves with my vps host name: vps11111.ovh.net

I find it annoying :slight_smile:

I then try to go to webmin/ Network config/ Host Addresses and I input those in:

11.111.111.11 ns1.mysite.com , ns1
22.222.222.22 ns2.mysite.com , ns2

By the way, those 2 ips I refer to are working IPs registered on my VPS

Still, host -t NS mysite.com resolves with my vps host name: vps11111.ovh.net

In webmin “Hostname and DNS Client”: (this page I really wished there was a Help file included as I understood nothing)

hostname is vps11111.ovh.net
box under is ticked

Resolution order : 1
1: Host files
2: DNS

DNS servers:
1: 127.0.0.1
2: Some IP I don’t know, maybe a master IP of my server vps11111.ovh.net?

Can someone help?
It all sounds too easy for most but not for me.

Howdy,

Well, "host -t NS mysite.com " is just showing your NS record for that domain. And so long as “vps11111.ovh.net” resolves to the IP address of one of your DNS servers, it should work perfectly.

The NS records just show which DNS server is responsible for hosting the domain’s record.

However, you could always change the NS record by going into Server Configuration -> DNS Record, and there you can change what it’s currently set to.

-Eric

Eric, Thanks for your answer but I couldn’t solve it,

I think there is something about this vps11111.ovh.net because even when I changed the NS in virtualmin to ns1.mysite.com, yes host -t NS mysite.com resolves to my ns1.mysite.com but still nothing works.

I am lost with this.
What did I miss??

Howdy,

Well, l don’t think the problem you’re seeing is related to that NS record.

Can you describe what issue it is that you’re seeing with DNS?

If you’re experiencing DNS problems, you may want to go to intodns.com and put one of your domains names in there to get DNS report. It can help in diagnosing DNS problems that are occurring.

-Eric