dns server (bind) not working??


I cannot manage to set up my bind server to work.
Everything seems ok…but no way.
Must I open port 53 after virtualmin pro install? Is it done automaticaly?
my name server is: ns1.auxe.net
Any help will be apreciated.


I guess the first thing you’d need to add to this problem report is: What exactly does “work” mean here? :slight_smile:

What exactly have you set up, what exactly have you tried, and what exactly happened instead of what you expected?

First a brief description of the server: new server with ubuntu 10.04 and virtualmin pro; all of this is still in test phase.
Everything works fine: is ok.

My machine name is: ns1.auxe.net and it is my dns server also (glue record has been created)

I cannot telnet this machine on port 53.
So my answer is: how can I check from my server that port 53 is closed? How can I open it? Why ubuntu did not open it automaticaly when installing bind9?

Thanks again.

I’m a little confused… Dig returns as IP address for “ns1.auxe.net”.

Which server exactly are you configuring? Which IP is the one in question? Which zones is the nameserver supposed to offer, and what are example hosts I can test? I need more info, sorry.

Hint: DNS resolutions usually use UDP and not TCP, that’s why you can’t “telnet” to a DNS server. Zone transfers are usually done via TCP though.

Hi Locutus…

Thanks for your time and your help.
The problem was that bind9 was only listening to localhost ( and not from internet.
I have changed it in Webmin -> Servers -> BIND DNS Server -> Addresses and Topology
And now it is ok.

I have 4 different ip on that server.
That is why you get confused about it.

My dns server now works ok. ns1.auxe.net ->

Thanks again.


Yeah, I can see you got help via support request meanwhile. Performing a netstat to see if the thing is listening, and checking iptables firewall, would have been my next suggestions too, after clearing up the “IP address confusion”. :slight_smile: Anyway, glad that it works now!