DNS RNDC issue

New virtualmin install because I lost some files on my OS drive, I’ve been manually reimporting my stuff to my new Virtualmin install fine, but I re-set up cluster DNS and added a new domain. It showed up on the other server with 0 records, when I try to apply the zone, I get

NDC command failed : rndc: ‘reload’ failed: empty label

I can apply all of the re-imported domains fine. What’s the problem with this new domain?

DNS host config file:

$ttl 38400
@ IN SOA ns1.lsncdn.net. admin.lostsignalweb.com. (
38400 )
@ IN NS ns1.lsncdn.net.
@ IN NS ns2.lsncdn.net
jmtz89.co.cc. IN A
www.jmtz89.co.cc. IN A
ftp.jmtz89.co.cc. IN A
m.jmtz89.co.cc. IN A
localhost.jmtz89.co.cc. IN A
webmail.jmtz89.co.cc. IN A
admin.jmtz89.co.cc. IN A
jmtz89.co.cc. IN TXT “v=spf1 a mx a:jmtz89.co.cc ip4: ?all”

A few initial hints, since I have not witnessed this problem yet myself.

  1. Are you maybe using Ubuntu? A quick Google search found some entries about an issue with Ubuntu and Webmin’s BIND module.

  2. Let’s try to find out if the call to RNDC fails, or if there’s some error in the zone file and the actual reload process fails. Go to Webmin -> Servers -> BIND DNS Server, choose the zone in question, and click “Check Records”. Does that yield any errors?

  3. See if RNDC is setup correctly. In the same Webmin section, click “Setup RNDC”. What does it say?

  4. In the same Webmin section, click “Edit Config File”, choose “named.conf.local” and see if the zone entry for the domain in question looks okay.

  5. You can also enable Webmin’s debug log, to see which commands exactly are executed. To do so, go to Webmin -> Webmin -> Webmin Configuration -> Debugging Log File and turn on “Debug log enabled” and at least “Commands executed”.

Looks like I figured it out… When setting up a Cluster DNS server you can set what the nameserver should be specified as with the template records. I put a period at the end of the name, not realizing it would automatically insert one, and didn’t notice the extra period at the end of the 2nd NS record

Right… I should have noticed the superfluous period in that NS record. :slight_smile: Anyway, I hope my hints were useful nevertheless. :wink: